Search bar alternatives need text labels

RESOLVED WONTFIX

Status

()

Firefox
Search
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: Sparhawk, Unassigned)

Tracking

43 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPEME?][WONTFIX?])

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8699225 [details]
Screenshot_at_20151217_09:42:12.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151215164008

Steps to reproduce:

* Click on the drop-down menu for the search bar, to select an alternative search engine.


Actual results:

* See icons for the various search engines.


Expected results:

* See text labels for the search engines.

Without text labels, it's impossible to differentiate many search engines (see attached screenshot). Previously, in FF 42.0, I could go to about:config and set browser.search.showOneOffButtons to false. However, this no longer works.

Arch Linux
FF 43.0

Updated

2 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Component: Untriaged → Search
OS: Unspecified → All
Hardware: Unspecified → All
Resolution: --- → DUPLICATE
Duplicate of bug: 1103315
(Reporter)

Comment 2

2 years ago
Hm, maybe I phrased it wrong. Ideally, I'm looking for the behaviour from previous versions of Firefox, with a list of text items, one engine per line.

At the moment (and I think what the proposed duplicate refers to), I can see a text label, but only if I hover over the icon. This is quite tedious. Hence, if I understand the linked bug correctly, I don't think this is duplicate.

(Removed dupe tag for now.)
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

2 years ago
Bug 1103315 is what handled the “multiple engines with identical icons” scenario. I maintain this is a duplicate of that, same as bug 1106333 and bug 1147333. If you feel very strongly otherwise, then at best this will be marked Wontfix; there's no room to fit labels in the current search UI, so that's not going to happen.
Whiteboard: [DUPEME?][WONTFIX?]
(Reporter)

Comment 4

2 years ago
The previous search UI fit the labels in fine, so I thought that a version similar to this would have worked. I'm not familiar enough with the (previous and current) icon-only view, but presumably you are saying that it has changed substantially that a reversion to the previous text-version is not workable. Could this not even be an optional setting?

Comment 5

2 years ago
workaround
(In reply to Sparhawk from comment #4)
> Could this not even be an optional setting?

No: bug 1119250.

You can get the old UI back with an add-on like Classic Theme Restorer.
https://addons.mozilla.org/firefox/addon/classicthemerestorer/
(Reporter)

Comment 6

2 years ago
Thank you for the information and links.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.