URL highlight gets chopped at the >

VERIFIED INVALID

Status

VERIFIED INVALID
17 years ago
14 years ago

People

(Reporter: jamesrome, Assigned: sspitzer)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
http://servicenews.symantec.com/cgi-bin/displayArticle.cgi?group=symantec.support.winnt.nortonantivirus2001.general&article=<1020104142209.2202362336@servicenews.symantec.com>&product=nav&mini_version=nav2001&tpre=sg

was in the reply to a question I asked to symantec. But the link stops after
symantec.com> and hence does not work.
(Reporter)

Comment 1

17 years ago
It shows up when I view this page, so I guess it is a browser issue...

Comment 2

17 years ago
RFC 2396 < ftp://ftp.isi.edu/in-notes/rfc2396.txt > clearly states in chapter
2.4.3. Excluded US-ASCII Characters that "<" and ">" are NOT allowed in an URI:

    "The angle-bracket "<" and ">" and double-quote (") characters are
    excluded because they are often used as the delimiters around URI in
    text documents and protocol fields."

Suggesting "invalid". Complain to Symantec!


Comment 3

17 years ago
Maybe I shouldn't have been so bold...

RFC 2396 states in the abstract:

    "This document does not define a generative
    grammar for URI; that task will be performed by the individual
    specifications of each URI scheme."

Which means that RFC 1738 should be consulted. As far as I can tell
from the productions in chapter 5, "<" and ">" belong to "punctuation".
Hence they can NOT be part of an URL.

Do people agree?

Comment 4

17 years ago
I agree :-)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.