Closed Bug 1233415 Opened 6 years ago Closed 5 years ago

Share icon from action bar is misaligned on some devices on landscape

Categories

(Firefox for Android Graveyard :: General, defect)

46 Branch
ARM
Android
defect
Not set
normal

Tracking

(firefox43 affected, firefox44 affected, firefox45 affected, firefox46 affected, fennec+, firefox53 fixed)

RESOLVED FIXED
Firefox 53
Tracking Status
firefox43 --- affected
firefox44 --- affected
firefox45 --- affected
firefox46 --- affected
fennec + ---
firefox53 --- fixed

People

(Reporter: TeoVermesan, Assigned: twointofive, Mentored)

References

Details

Attachments

(3 files)

Device: ZTE x86 (Android 4.0.4), Alcatel One Touch (Android 4.1.2)

Steps to reproduce:
1. Load a page
2. Long tap on a word

Expected result:
- The icons from action bar are correctly aligned.

Actual result:
- Share icon is misaligned.
Teodora, which class of devices does this occur on (e.g. 7" tablets, 10" tablets, phones)? Is it mixed?

I think this could be related to removing the whitespace from various icons in the UI.
Flags: needinfo?(teodora.vermesan)
I could reproduce the issue on:
Alcatel OT-8008D: 5.0"
Prestigio  PSP5508DUO: 5.0'"
ZTE Grand X: 4.3"
Motorola X: 4.7"

I could not reproduce the issue on:
Nexus 6: 5.96"
Samsung S6 Edge: 5.1"
Flags: needinfo?(teodora.vermesan)
tracking-fennec: --- → ?
This looks pretty bad, we should fix this at some point, maybe as part of a polish sprint.
Mentor: michael.l.comella
tracking-fennec: ? → +
How this can be tested without owning one of those devices? Is the emulator enough for trying?
(In reply to Francisco Jordano [:arcturus] [:francisco] from comment #4)
> How this can be tested without owning one of those devices? Is the emulator
> enough for trying?

It might be – best thing to do is try it out! :)
I'm able to reproduce on a Nexus 5 emulator in landscape mode.

That's an interesting path to add action items to the action bar :)

The "Share" icon is wider than tall, whereas the other action icons are square.  I don't understand why that only causes the Share icon to be too short in landscape mode on certain phones (internal layout calculations I guess?), but setting layout_height="match_parent" on the action view seems to fix it.
Assignee: nobody → twointofive
Comment on attachment 8824814 [details]
Bug 1233415 - Make action bar actions full action bar height.

https://reviewboard.mozilla.org/r/103090/#review104248
Attachment #8824814 - Flags: review?(s.kaspari) → review+
Pushed by twointofive@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/edcbb6e741c9
Make action bar actions full action bar height. r=sebastian
https://hg.mozilla.org/mozilla-central/rev/edcbb6e741c9
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 53
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.