Closed Bug 12335 Opened 20 years ago Closed 20 years ago

[BLOCKER] [PP] MsgCompose's Menu bar displays random characters and crash

Categories

(MailNews Core :: Composition, defect, P1, blocker)

PowerPC
Mac System 8.5
defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: bugzilla, Assigned: saari)

References

Details

(Whiteboard: Working on it)

When you start Apprunner and then select File/New Message, the menu bar of the message compose window display a
long string of random characters. If you click on the menubar, it crash. When you start apprunner directly with the
msg compose window (-compose), menus are fine!

The problem occurs even if I replace all the menus in messengercompose.xul by:

  <menubar>
	<menu value="File">
	<menupopup>
		<menuitem value="Quit"/>
	</menupopup>
	</menu>
  </menubar>
Severity: normal → critical
*** Bug 12480 has been marked as a duplicate of this bug. ***
Severity: critical → blocker
Summary: [PP] MsgCompose's Menu bar displays random characters and crash → [BLOCKER] [PP] MsgCompose's Menu bar displays random characters and crash
I need to raise this to a blocker.  Per the other duplicate bug, we cannot test
full attachment functionality (which we need via the menus) with this problem.

Any update to this bug? Thanks.
Status: NEW → ASSIGNED
Priority: P3 → P1
Whiteboard: Working on it
Target Milestone: M10
Did this appear recently?
Not really, I saw it first 1 or two weeks ago but it was hard to reproduce. Now it's almost every time when you open
the message compose window from the browser.
weird. I'll let you know if I figure out what is going on.
other side effect of this problem is that after you get the menu bar corrupted, the submenus under the Apple Menu
doesn't show up anymore! Even after quitting Apprunner and even if you turn them off and then on with the control
panel "Apple Menu options". You must restart your Mac to get them back.
I've got the bug nailed. I'll check in the fix when the tree goes green.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Fixed
Status: RESOLVED → VERIFIED
Mac (1999-09-15-08 M11)
This problem has been fixed.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.