Arabic text with with repeated combining mark shows very tall trail of combining marks

RESOLVED INVALID

Status

()

Core
Graphics: Text
RESOLVED INVALID
2 years ago
2 years ago

People

(Reporter: SpeciesX, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

2 years ago
Created attachment 8699578 [details]
11.PNG

And here how it looks like.






ؤْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْ ؤْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْ ؤْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْ ؤْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْ ؤْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْ  ؤْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْؤْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْؤْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْْ
I also see this, on Windows 10, just viewing this bug.

What platform are you on?
Component: Layout: Text → Graphics: Text
Summary: Arabic font bug → Arabic font shows trail of marks up and slightly diagonal (not repaint related)
Created attachment 8699844 [details]
screenshot of part of this bug report, showing the bug
Then again, what's happening here is that there's a character:
0624;ARABIC LETTER WAW WITH HAMZA ABOVE
followed by a very large sequence of:
0652;ARABIC SUKUN
so it's just a huge pile of combining marks on top of the same character.
Seems like this is might be the right thing to do.
Summary: Arabic font shows trail of marks up and slightly diagonal (not repaint related) → Arabic text with with repeated combining mark shows very tall trail of combining marks
I don't see a problem here. The content may be silly, but we're doing the right thing with it; how else would it be expected to appear?
It does not render like the screenshot on linux. So if that is the intended behaviour, do we have a bug on linux (or other non-windows-10 platforms)?
(Reporter)

Comment 7

2 years ago
Created attachment 8699995 [details]
edge & IE11

On my Android 5 Phone and Firefox nightly i have the same behavior and on the Internet App is looks similar, but the ARABIC SUKUN going strait up.
The exact behavior will depend on the font. If the font has mark-to-mark positioning features, the marks should stack accordingly -- that's what leads to the slightly-diagonal stacking in some cases. Without the relevant OpenType features, you're likely to see just straight-up stacking using harfbuzz's default mark-positioning heuristics.

(In reply to Jamie Nicol [:jnicol] from comment #6)
> It does not render like the screenshot on linux. So if that is the intended
> behaviour, do we have a bug on linux (or other non-windows-10 platforms)?

It's likely just a matter of what mark-positioning features are present (or not) in the particular font being used. If you think something else is wrong, please confirm what font it's using on your system, and attach a screenshot.
(In reply to SpeciesX from comment #7)
> Created attachment 8699995 [details]
> edge & IE11

Ah, that's because Microsoft doesn't think people should put more than one vowel mark on an Arabic letter (because that shouldn't normally be needed in real Arabic text). So they insert dotted circles for the marks that they consider spurious. But there's no fundamental reason why multiple diacritics shouldn't be stacked; it's perfectly valid as a sequence of Unicode characters, even if it's not sensible Arabic-language text.
(In reply to blinky from comment #10)
> Regression range:
> http://hg.mozilla.org/mozilla-central/
> pushloghtml?fromchange=baa6cc2f72e4&tochange=be4b69a4babf

But it's not a regression; the behavior is correct (and better than we used to have in the pre-harfbuzz days).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.