Closed Bug 1233590 Opened 4 years ago Closed 4 years ago

[non-e10s] Fixed Background Images show incorrectly Behind Rounded Object

Categories

(Core :: Graphics: Layers, defect)

43 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1232939
Tracking Status
e10s - ---
firefox42 --- unaffected
firefox43 --- wontfix
firefox44 + wontfix
firefox45 + fixed
firefox46 + fixed
firefox-esr38 --- unaffected

People

(Reporter: mozilla, Assigned: botond)

References

Details

(Keywords: regression, site-compat, testcase, Whiteboard: gfx-noted)

Attachments

(3 files)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151208100201

Steps to reproduce:

Assign background image to body of website using CSS.
Create DIV with rounded corners in front of background.

See this site: http://harborfitllc.com


Actual results:

Background is not drawn around rounded corners if it is assigned a "fixed" position.


Expected results:

Background should be drawn correctly.
Component: Untriaged → Layout: Images
Product: Firefox → Core
Component: Layout: Images → Layout: View Rendering
I can reproduce on Nightly46.0a1 with *DISABLED* e10s. 
(It have been fixed by Bug 1208438 in case of enabled e10s.)

Regression window.
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=63cc176d76a66b1807ea4b9500651063032123b1&tochange=d24b11e4beb29e7b0941121b93b10fc155c53a4e

Regressed by: Bug 1166301
Blocks: 1166301
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(botond)
Keywords: regression
Summary: Fixed Background Images show incorrectly Behind Rounded Object → [non-e10s] Fixed Background Images show incorrectly Behind Rounded Object
Attached file reduced testcase
Attached file testcase
Keywords: testcase
Component: Layout: View Rendering → Graphics: Layers
See Also: → 1232939
Interestingly, I can't reproduce the issue on any of the testcases in this bug, but I _can_ reproduce it on the reduced testcase in bug 1232939, which appears to be the same or a very similar issue.
Doc posted for Bug 1232939.
Keywords: dev-doc-needed
Whiteboard: gfx-noted
Tracking as this is a recent regression (from 43).
Once we have a fix for bug 1232939, we can test against this bug.
Assignee: nobody → botond
The testcase I ended up adding to the test suite for bug 1232939 is based on the "reduced testcase" in this bug. I believe they are the same issue.
Flags: needinfo?(botond)
No longer reproduced the problem with attachment 8699869 [details] and attachment 8699871 [details] both.

Fixed range:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=70094106841ccb97143d59df7769c5ead0336832&tochange=110fb501fa45c60c25c3fa0d53fb643cb7839bed
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1232939
Thanks for testing!
Marking fixed for 45 and 46 based on bug 1232939.
Wontfix for 44 since its duplicate bug is also wontfixed.
You need to log in before you can comment on or make changes to this bug.