Running profile manager causes the browser to open www.manager.com on first run

RESOLVED INVALID

Status

()

Toolkit
Startup and Profile System
RESOLVED INVALID
2 years ago
a year ago

People

(Reporter: fabrix.jf, Unassigned)

Tracking

43 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36

Steps to reproduce:

- Run "firefox manager -p" in command line.
- Select a profile (doesn't matter if a new one is created)
- Click "Start Firefox"


Actual results:

Firefox starts with the website http://www.manager.com opened at startup


Expected results:

Firefox should start with the default start page opened.
(Reporter)

Updated

2 years ago
Severity: normal → major

Comment 1

2 years ago
Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0
20151208200940

Works for me.
Severity: major → normal
Component: Untriaged → Startup and Profile System
Product: Firefox → Toolkit

Comment 2

a year ago
This is the expected behavior. If you pass "manager" on the command line, we treat that as an argument and try to open it as a file or URL. If you want the default start page, just run `firefox -P`
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.