If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Scrubber disappears when moved on element with multiple animations

RESOLVED WORKSFORME

Status

()

Firefox
Developer Tools: Animation Inspector
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: pbro, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8699948 [details]
pulse.html

STR:
- open the attached HTML test case
- open the inspector, select the div and switch to the animation inspector tab
- you should see 2 animations, that's because the div has 2 css keyframe animations defined
- click anywhere in the time graduation header in order to move the scrubber to that position

=> Expected: the scrubber moves there and the animation pauses
=> Actual: the scrubber disappears, the animation pauses correctly though

Looks like the whole timeline is refreshed when this happens.

Now, try removing one of the animations (you can do this in the rule-view for instance). Switching back to the animation tab does the right thing, only one animation is displayed now, and clicking/dragging the scrubber does work.
I can't reproduce this bug in Nightly. The animation pauses and I still see the scrubber.
Can you tell me if you can reproduce ?
Flags: needinfo?(pbrosset)
(Reporter)

Comment 2

2 years ago
Can't reproduce anymore either. Closing as WFM.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(pbrosset)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.