Stop using hardcoded version of iOS to use the product details

RESOLVED DUPLICATE of bug 1290691

Status

RESOLVED DUPLICATE of bug 1290691
3 years ago
2 years ago

People

(Reporter: sylvestre, Unassigned)

Tracking

Development/Staging

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [kb=1931912] )

(Reporter)

Description

3 years ago
Currently we have to do this kind of PR after each version of iOS:
https://github.com/mozilla/bedrock/pull/3678

We should extend the new version of the product-details:
https://product-details.mozilla.org/
to have ios version
We have https://product-details.mozilla.org/mobile_details.json for now (but values are hardcoded here too)
Paul and Josh, any insights into how to approach this?
Whiteboard: [kb=1931912]
We can easily switch to using these values from product-details.m.o as soon as we start using that site as the source for product-details. Even if they're hard coded for now, :sylvestre and crew can (I assume) more easily update that than bedrock, and then it can be automated when possible without affecting bedrock.

So this is blocked by product-details.m.o's readiness for production use. As soon as that's ready and we switch to it we can update the code in bedrock to use these values.
(Reporter)

Updated

2 years ago
Blocks: 1288169
Oh I didn't notice this bug! Dup'ing as I've already sent a PR.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1290691
You need to log in before you can comment on or make changes to this bug.