If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[traceback] jinja2.exceptions:UndefinedError on /oneanddone.tasks.views:TaskDetailView.get

VERIFIED FIXED

Status

Mozilla QA
One and Done
--
critical
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: stephend, Assigned: bsilverberg)

Tracking

Version 3

Details

(Whiteboard: [fromAutomation], URL)

(Reporter)

Description

2 years ago
https://oneanddone.mozilla.org/tasks/76/ is throwing a 500.

New Relic: https://rpm.newrelic.com/accounts/263620/applications/3612614/traced_errors/91164d-1e9e2280-a5ac-11e5-8436-c81f66b8ceca

(But there's no stack, sadly, other than "jinja2.exceptions:UndefinedError

/oneanddone.tasks.views:TaskDetailView.get" due to 'Message removed by New Relic 'strip_exception_messages' setting'
(Reporter)

Comment 1

2 years ago
https://webqa-ci.mozilla.com/view/One%20and%20Done/job/oneanddone.prod.saucelabs/50/
(Reporter)

Updated

2 years ago
Whiteboard: [fromAutomation]
(Assignee)

Comment 2

2 years ago
Thanks Stephen. This is related to bug 1232869 and is being caused by a user deleting their profile. I have fixed the data manually for now, so fix this error, but bug 1232869 should fix it permanently.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
(Reporter)

Comment 3

2 years ago
Thx Bob - this has gone away now; verified in production.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.