Closed Bug 1233894 Opened 4 years ago Closed 4 months ago

Remove deprecated-sync-thenables library

Categories

(DevTools :: Framework, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1233891

People

(Reporter: jryans, Unassigned)

References

Details

Once all usages of deprecated-sync-thenables are gone, we can remove it entirely.
Product: Firefox → DevTools

Gonna throw this ni to Alex as well.

Flags: needinfo?(poirot.alex)

Yes. But be careful to run all Devtools tests on try, breakage and intermittent failure are expected.
As its name says, these promises resolve synchronously and some is this code was known to depend on this behavior.
So removing them should involve understanding why and try to mitigate the dependency on synchronous code.

If there is any failure, we may try to remove the usages from tests first and only from debugger-client or thread-client.
It is not clear if all the leftover usages are relevant.

Flags: needinfo?(poirot.alex)
Flags: needinfo?(jryans)

Fixed in bug 1233891.

Status: NEW → RESOLVED
Closed: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1233891
You need to log in before you can comment on or make changes to this bug.