improve error reporting for b2g_bumper stamp failures

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
6 months ago

People

(Reporter: hwine, Assigned: hwine)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [b2g_bumper])

Attachments

(2 attachments)

(Assignee)

Description

3 years ago
I spent 1/2 the time finding the config with problems for bug 1233351 - we can do better.

b2g_bumper/files/run_b2g_bumper.sh
(Assignee)

Comment 1

3 years ago
Sigh. Too quick to enter.

Two issues:
 1) runner script doesn't say which branch failed. That's in run_b2g_bumper.sh
 2) log file just shows stack trace:
    213 20:50:19    FATAL - Uncaught exception: Traceback (most recent call last):
    214 20:50:19    FATAL -   File "/builds/b2g_bumper/mozharness/mozharness/base/script.py", line 1693, in run
    215 20:50:19    FATAL -     self.run_action(action)
    216 20:50:19    FATAL -   File "/builds/b2g_bumper/mozharness/mozharness/base/script.py", line 1635, in run_action
    217 20:50:19    FATAL -     self._possibly_run_method(method_name, error_if_missing=True)
    218 20:50:19    FATAL -   File "/builds/b2g_bumper/mozharness/mozharness/base/script.py", line 1576, in _possibly_run_method
    219 20:50:19    FATAL -     return getattr(self, method_name)()
    220 20:50:19    FATAL -   File "/builds/b2g_bumper/mozharness/scripts/b2g_bumper.py", line 595, in push_loop
    221 20:50:19    FATAL -     self.massage_manifests()
    222 20:50:19    FATAL -   File "/builds/b2g_bumper/mozharness/scripts/b2g_bumper.py", line 508, in massage_manifests
    223 20:50:19    FATAL -     self.map_remotes(manifest)
    224 20:50:19    FATAL -   File "/builds/b2g_bumper/mozharness/scripts/b2g_bumper.py", line 146, in map_remotes
    225 20:50:19    FATAL -     repo_manifest.rewrite_remotes(manifest, mapping_func)
    226 20:50:19    FATAL -   File "/builds/b2g_bumper/mozharness/mozharness/mozilla/repo_manifest.py", line 83, in rewrite_remotes
    227 20:50:19    FATAL -     m = mapping_func(r)
    228 20:50:19    FATAL -   File "/builds/b2g_bumper/mozharness/scripts/b2g_bumper.py", line 144, in mapping_func
    229 20:50:19    FATAL -     self._remote_mappings[m.getAttribute('fetch')] = orig_url
    230 20:50:19    FATAL - AttributeError: 'NoneType' object has no attribute 'getAttribute'

There's only one cause for that error - a remote can't be found in the
config. Let's make that more explicit.
(Assignee)

Comment 2

3 years ago
Created attachment 8700275 [details] [diff] [review]
run.patch

Improve time to resolution by not discarding information about _which_ branch(es) are having problems.
Assignee: nobody → hwine
Status: NEW → ASSIGNED
Attachment #8700275 - Flags: review?(jlund)
(Assignee)

Comment 3

3 years ago
Created attachment 8700276 [details] [diff] [review]
b2g_bumper.patch

Avoid the hard-to-decipher-late-on-a-Friday-night stack trace in comment 1, and give a clue as to where the problem is.
Attachment #8700276 - Flags: review?(jlund)

Updated

3 years ago
Attachment #8700275 - Flags: review?(jlund) → review+

Updated

3 years ago
Attachment #8700276 - Flags: review?(jlund) → review+
(Assignee)

Comment 4

3 years ago
I think these are safe to land by anyone, as any side effects should be quickly apparent.

However, ni myself to land after PTO just in case.
Flags: needinfo?(hwine)
(Assignee)

Comment 7

3 years ago
Comment on attachment 8700276 [details] [diff] [review]
b2g_bumper.patch

in production with
  https://hg.mozilla.org/build/mozharness/rev/5792bcee8f5f
Attachment #8700276 - Flags: checked-in+
(Assignee)

Comment 8

3 years ago
Comment on attachment 8700275 [details] [diff] [review]
run.patch

In production with:
  https://hg.mozilla.org/build/puppet/rev/ff7fe1d132ae
Flags: needinfo?(hwine)
Attachment #8700275 - Flags: checked-in+
(Assignee)

Updated

3 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Component: General Automation → General
Product: Release Engineering → Release Engineering
You need to log in before you can comment on or make changes to this bug.