The default bug view has changed. See this FAQ.

Hatena Blog (ACE editor) show wrong conversion candidates Japanese IME

RESOLVED INVALID

Status

()

Core
Layout: Text
RESOLVED INVALID
a year ago
a year ago

People

(Reporter: PRiMENON, Unassigned)

Tracking

({inputmethod, regression, site-compat})

46 Branch
x86_64
All
inputmethod, regression, site-compat
Points:
---

Firefox Tracking Flags

(firefox42 unaffected, firefox43 unaffected, firefox44 unaffected, firefox45 unaffected, firefox46 unaffected, firefox-esr38 unaffected)

Details

Attachments

(2 attachments)

(Reporter)

Description

a year ago
Created attachment 8700389 [details]
hatenablogbug.gif

Build identifier: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:46.0) Gecko/20100101 Firefox/46.0
Windows 10 Home.

Steps to reproduce:
1.setting clean profile
2.open hatena blog, new entry link(heading navigation),and swtiching "HTML" tab.
3.turn on Google Japanese IME.
4.type to "日本語"

Actual results:
show wrong conversation candidate.

Expected results:
show correct conversation candidate.

Other browser results:
47.0.2526.106 m (64-bit) is fine.
Microsoft Edge 25.10586.0.0(Microsoft EdgeHTML 13.10586) is fine.

Updated

a year ago
Component: General → Widget: Win32
Keywords: inputmethod
Product: Firefox → Core

Comment 1

a year ago
Reproduced on Ubuntu14.04 32bit fcitx-mozc and Windows7 MS-IME.

Because Hatena insert "\x01\x01" when I type composition text for something ACE editor.
(See https://blog.st-hatena.com/js/vendor/ace-builds/src/ace.js?version=76b2f02d7b63d6a752497edddfee6d2e)

These control chars are visible on Gecko since Firefox30. see Bug 909344.
Unfortunately, Bug 947588 dis not fix this.

Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=d59e42825c44&tochange=f0d6d67fbc1e
Blocks: 909344
Status: UNCONFIRMED → NEW
status-firefox42: --- → affected
status-firefox43: --- → affected
status-firefox44: --- → affected
status-firefox45: --- → affected
status-firefox46: --- → affected
status-firefox-esr38: --- → affected
status-firefox-esr45: --- → ?
Component: Widget: Win32 → Layout: Text
Ever confirmed: true
Keywords: regression, site-compat
OS: Windows 10 → All

Updated

a year ago
Flags: needinfo?(jfkthame)

Comment 2

a year ago
This site is also affected https://ace.c9.io/#nav=about
Summary: Hatena Blog show wrong conversion candidates Japanese IME → Hatena Blog (ACE editor) show wrong conversion candidates Japanese IME

Comment 3

a year ago
Created attachment 8700404 [details]
Bug 1234039 control char.html
ISTM this is a site bug: they shouldn't be inserting those control characters into the editable element if they don't want them to appear. According to the CSS WG resolution, all browsers should eventually converge on making them visible, so the "problem" is likely to spread unless the editor code is fixed.
Flags: needinfo?(jfkthame)
filed https://github.com/ajaxorg/ace/issues/2855
Flags: needinfo?(bugs)
I agree with the diagnosis that this should be fixed in the ACE IME as per comment 5.
Status: NEW → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(bugs)
Resolution: --- → INVALID
status-firefox42: affected → unaffected
status-firefox43: affected → unaffected
status-firefox44: affected → unaffected
status-firefox45: affected → unaffected
status-firefox46: affected → unaffected
status-firefox-esr38: affected → unaffected
status-firefox-esr45: ? → ---
You need to log in before you can comment on or make changes to this bug.