Closed Bug 1234045 Opened 5 years ago Closed 5 years ago

Intermittent testNewTab | Exception caught - java.lang.NullPointerException (at android.view.ViewGroup.findViewTraversal(ViewGroup.java:1760))

Categories

(Firefox for Android Graveyard :: General, defect)

defect
Not set
normal

Tracking

(firefox46 affected)

RESOLVED DUPLICATE of bug 1207877
Tracking Status
firefox46 --- affected

People

(Reporter: aryx, Assigned: gbrown)

Details

(Keywords: intermittent-failure)

https://treeherder.mozilla.org/logviewer.html#?job_id=18815431&repo=mozilla-inbound

07:46:15     INFO -  TEST-PASS | testNewTab | Given message occurred for registered event: {"type":"Content:PageShow","userRequested":"","tabID":2} - Content:PageShow should equal Content:PageShow
07:46:15     INFO -  EventExpecter: no longer listening for Content:PageShow
07:46:15     INFO -  TEST-PASS | testNewTab | waiting for urlbar text to gain focus - urlbar text gained focus
07:46:15     INFO -  0 ERROR Exception caught during test! - java.lang.NullPointerException
07:46:15     INFO -  	at android.view.ViewGroup.findViewTraversal(ViewGroup.java:1760)
07:46:15     INFO -  	at android.view.View.findViewById(View.java:7904)
07:46:15     INFO -  	at android.view.ViewGroup.findViewTraversal(ViewGroup.java:1761)
07:46:15     INFO -  	at android.view.View.findViewById(View.java:7904)
07:46:15     INFO -  	at android.view.ViewGroup.findViewTraversal(ViewGroup.java:1761)
07:46:15     INFO -  	at android.view.View.findViewById(View.java:7904)
07:46:15     INFO -  	at android.view.ViewGroup.findViewTraversal(ViewGroup.java:1761)
07:46:15     INFO -  	at android.view.View.findViewById(View.java:7904)
07:46:15     INFO -  	at android.view.ViewGroup.findViewTraversal(ViewGroup.java:1761)
07:46:15     INFO -  	at android.view.View.findViewById(View.java:7904)
07:46:15     INFO -  	at android.view.ViewGroup.findViewTraversal(ViewGroup.java:1761)
07:46:15     INFO -  	at android.view.View.findViewById(View.java:7904)
07:46:15     INFO -  	at android.view.Window.findViewById(Window.java:741)
07:46:15     INFO -  	at android.app.Activity.findViewById(Activity.java:1647)
07:46:15     INFO -  	at com.jayway.android.robotium.solo.Getter.getView(Getter.java:118)
07:46:15     INFO -  	at com.jayway.android.robotium.solo.Getter.getView(Getter.java:137)
07:46:15     INFO -  	at com.jayway.android.robotium.solo.Solo.getView(Solo.java:1982)
07:46:15     INFO -  	at com.jayway.android.robotium.solo.Solo.getView(Solo.java:1970)
07:46:15     INFO -  	at org.mozilla.gecko.tests.BaseTest.enterUrl(BaseTest.java:154)
07:46:15     INFO -  	at org.mozilla.gecko.tests.BaseTest.inputAndLoadUrl(BaseTest.java:188)
07:46:15     INFO -  	at org.mozilla.gecko.tests.BaseTest.addTab(BaseTest.java:585)
07:46:15     INFO -  	at org.mozilla.gecko.tests.testNewTab.addTab(testNewTab.java:16)
07:46:15     INFO -  	at org.mozilla.gecko.tests.testNewTab.testNewTab(testNewTab.java:43)
07:46:15     INFO -  	at java.lang.reflect.Method.invokeNative(Native Method)
07:46:15     INFO -  	at java.lang.reflect.Method.invoke(Method.java:507)
07:46:15     INFO -  	at android.test.InstrumentationTestCase.runMethod(InstrumentationTestCase.java:204)
07:46:15     INFO -  	at android.test.InstrumentationTestCase.runTest(InstrumentationTestCase.java:194)
07:46:15     INFO -  	at android.test.ActivityInstrumentationTestCase2.runTest(ActivityInstrumentationTestCase2.java:186)
07:46:15     INFO -  	at org.mozilla.gecko.tests.BaseRobocopTest.runTest(BaseRobocopTest.java:188)
07:46:15     INFO -  	at junit.framework.TestCase.runBare(TestCase.java:127)
07:46:15     INFO -  	at junit.framework.TestResult$1.protect(TestResult.java:106)
07:46:15     INFO -  	at junit.framework.TestResult.runProtected(TestResult.java:124)
07:46:15     INFO -  	at junit.framework.TestResult.run(TestResult.java:109)
07:46:15     INFO -  	at junit.framework.TestCase.run(TestCase.java:118)
07:46:15     INFO -  	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:169)
07:46:15     INFO -  	at android.test.AndroidTestRunner.runTest(AndroidTestRunner.java:154)
07:46:15     INFO -  	at android.test.InstrumentationTestRunner.onStart(InstrumentationTestRunner.java:529)
07:46:15     INFO -  	at android.app.Instrumentation$InstrumentationThread.run(Instrumentation.java:1448)
07:46:15  WARNING -  TEST-UNEXPECTED-FAIL | testNewTab | Exception caught - java.lang.NullPointerException
The last time this test was changed was bug 1217484, but all we did was wait longer so I'm not sure it would cause this.
NI self to investigate.
Flags: needinfo?(michael.l.comella)
addTab() no longer calls inputAndLoadUrl() due to...
Assignee: nobody → gbrown
Status: NEW → RESOLVED
Closed: 5 years ago
Flags: needinfo?(michael.l.comella)
Resolution: --- → DUPLICATE
Duplicate of bug: 1207877
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.