chrome.notifications.create() ignores options.iconUrl

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
3 years ago
3 months ago

People

(Reporter: chef, Unassigned)

Tracking

46 Branch
x86_64
Windows

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36

Steps to reproduce:

Call chrome.notifications.create('foo', {title: 'foo', message: 'bar', iconUrl: <relative path to png file>})


Actual results:

Notification appears without image specified by iconUrl.


Expected results:

Notification appears with image specified by iconUrl.
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows
Hardware: Unspecified → x86_64
(Reporter)

Comment 1

3 years ago
It appears that the root cause is that FF is evaluating the path as case-sensitive.

Not sure if requests for extension resources should be changed for Windows/OS X platforms to be case-insensitive instead. Eg, for consistency with Chrome's behavior on those platforms.
Thanks for investigating. I think we'll probably stick with our current behavior unless a lot of other people report this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX

Updated

3 months ago
Product: Toolkit → WebExtensions
You need to log in before you can comment on or make changes to this bug.