If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

19x browser_action icon appears scaled down

RESOLVED DUPLICATE of bug 1200674

Status

()

Toolkit
WebExtensions: Untriaged
RESOLVED DUPLICATE of bug 1200674
2 years ago
2 years ago

People

(Reporter: Hans Meyer, Unassigned)

Tracking

46 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Created attachment 8700437 [details]
browser_action_icon_original_displayed.PNG

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20151220030223

Steps to reproduce:

Specified browser_action icon in manifest as follows:

"browser_action": {
    "default_icon": {
      "19": "img/icon19.png",
      "38": "img/icon38.png"
    }
  }

Confirmed icon19.png is 19x19 px


Actual results:

Icon as displayed in toolbar is scaled down, with undesirable results (blurry effect)
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
This is the expected behavior. Firefox uses 18×18px or 36×36px icons for toolbar buttons, and 32×32px or 64×64px icons for the menu panel.

If you want unscaled icons, you need to include icons with those sizes.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1200674
You need to log in before you can comment on or make changes to this bug.