Status

Hello (Loop)
Client
P1
normal
Rank:
11
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: RT, Assigned: dcritch)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

User Story

Acceptance criteria:
- Resize automatically the panel height if the list includes between 0 and 5 conversations
- Resize automatically the panel height when the user is in a room and opens the panel
- Set a fixed panel height if the panel includes 5 conversations or more

See attached documents for details on panel height based on number of conversations.

Attachments

(4 attachments)

Comment hidden (empty)
(Reporter)

Comment 1

2 years ago
Created attachment 8700569 [details]
Expanding Panel.png
(Reporter)

Updated

2 years ago
User Story: (updated)
(Reporter)

Updated

2 years ago
Rank: 25
Priority: -- → P2
(Reporter)

Updated

2 years ago
Blocks: 1209713
I would like to work on this item.
(Reporter)

Comment 3

2 years ago
Created attachment 8701444 [details]
Stop sharing tabs.png
(Reporter)

Updated

2 years ago
User Story: (updated)
(Assignee)

Updated

2 years ago
Assignee: nobody → dcritchley
(Reporter)

Updated

2 years ago
Rank: 25 → 15
(Reporter)

Updated

2 years ago
Priority: P2 → P1

Updated

2 years ago
Blocks: 1226607
Rank: 15 → 11
(Assignee)

Comment 4

2 years ago
There is a min-height on the panel built into the browser. So we can't go any smaller than 214px without changing that parameter in the browser, which may have an impact other panels. My recommendation would be to stick with the 214px min height within our app for now and pursue having the panel min height changed for a release down the road, if we want to continue down that route. Should we proceed with working around the min-height?
Flags: needinfo?(sfranks)
Are we sure it's not simple to override? The downloads panel can be smaller than 214px (http://i.sevaan.com/0A1G1R1s033G)

If it's a real issue, I'm okay staying with 214px for the moment. It's still shorter than what the panel is now.
Flags: needinfo?(sfranks)

Comment 6

2 years ago
dcritch, where are you seeing the min-height being set by the browser?
(Assignee)

Comment 8

2 years ago
Created attachment 8712223 [details]
Screenshots of new panel layout for review
Attachment #8712223 - Flags: ui-review?(sfranks)
Created attachment 8712232 [details] [review]
[loop] daveccrit:1234183-resizePanel > mozilla:master
(Assignee)

Updated

2 years ago
Attachment #8712232 - Flags: review?(standard8)
Attachment #8712232 - Flags: review?(edilee)
Attachment #8712232 - Flags: review?(dmose)
Attachment #8712223 - Flags: ui-review?(sfranks) → ui-review+
Comment on attachment 8712232 [details] [review]
[loop] daveccrit:1234183-resizePanel > mozilla:master

I'm going to skip review on this and leave it to Dan/Ed.
Attachment #8712232 - Flags: review?(standard8)
Comment on attachment 8712232 [details] [review]
[loop] daveccrit:1234183-resizePanel > mozilla:master

Ed's already doing review for the pointer sharing; I'll pick this up tomorrow.
Attachment #8712232 - Flags: review?(edilee)
Comment on attachment 8712232 [details] [review]
[loop] daveccrit:1234183-resizePanel > mozilla:master

Looks great; thanks for the ui-showcase SVG icon cleanup as well as the auto-resizing code.  r=dmose with the nits in the PR fixed if there are no mochitest changes required.  If mochitest changes are required, I'd like to have one more look.
Attachment #8712232 - Flags: review?(dmose) → review+
One issue I noticed while testing, and this may or may not be a problem on master too: when testing on a profile for the first time with no rooms, I could create the first room, and it would work, but not appear in the panel.  All subsequent attempts (eg delete that room and create a new one) didn't have that problem.

It's not obvious to me that this would be caused by this patch, but please check before landing.
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Depends on: 1249577
You need to log in before you can comment on or make changes to this bug.