"Keep your data" doesn't work if you flash from Android to Firefox OS

RESOLVED FIXED

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jlorenzo, Assigned: gerard-majax)

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
If you come from Android and already have some data (like phone calls or text messages), this button can give false hope to the end-user. 

As converting the data, from Android to Firefox OS, is likely not an easy task, I'd either change the label, or make the button un-selected and greyed out if we detect a non-Firefox OS phone.
(Assignee)

Updated

3 years ago
Depends on: 1235819
(Assignee)

Comment 1

3 years ago
Let's go with the disabling of the button on Android device :)
(Assignee)

Comment 2

3 years ago
Created attachment 8712096 [details] [diff] [review]
Detect B2G early and disable Keep Data
Attachment #8712096 - Flags: review?(dale)
(Assignee)

Updated

3 years ago
Assignee: nobody → lissyx+mozillians
(Assignee)

Comment 3

3 years ago
Comment on attachment 8712096 [details] [diff] [review]
Detect B2G early and disable Keep Data

Let's land this.
Attachment #8712096 - Flags: review?(dale) → review+
(Assignee)

Comment 4

3 years ago
Created attachment 8713131 [details] [review]
PR of the patch
Attachment #8713131 - Flags: review+
(Assignee)

Comment 5

3 years ago
https://github.com/mozilla-b2g/b2g-installer/commit/cf9538f77914d692e7c53af0f890ad517f46910d
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1235819
You need to log in before you can comment on or make changes to this bug.