Strings for SendTo extension cannot be used in two targets

VERIFIED FIXED

Status

()

Firefox for iOS
General
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: st3fan, Assigned: st3fan)

Tracking

unspecified
Other
iOS

Firefox Tracking Flags

(fxios2.0+)

Details

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
The SendTo extension used to have two swift files that have localized strings:

 ClientPickerViewController.swift
 InstructionsViewController.swift

Doing a string export resulted in a section in the xliff named Extensions/SendTo/SendTo.strings


Since the Peek & Pop feature, the above two controllers are also used in the main app as part of the Send Tab Quick Action under the Peek.

Because of that these files are now part of both the Client and the SendTo targets.

That is good for code sharing, but from a strings perspective this won't work because localized strings can only be part of one bundle. So only one of the targets will get them.

It is also not possible for an extension to get the strings from its parent bundle (the app in which it is contained).

Not entirely sure what to do here.

One solution is that we manually copy the strings as part of the import-locales scripts. We do more whacky stuff there so this would be in line with that :-/
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1240540
(Assignee)

Updated

2 years ago
Assignee: nobody → sarentz
(Assignee)

Comment 2

2 years ago
New script now knows about files that need to be duplicated:

Exporting firefox-ios-l10n/it/firefox-ios.xliff
  Writing Client/3DTouchActions.strings to Client/it.lproj/3DTouchActions.strings
  Writing Client/AuthenticationManager.strings to Client/it.lproj/AuthenticationManager.strings
  Writing Client/BookmarkPanel.strings to Client/it.lproj/BookmarkPanel.strings
  Writing Client/ClearHistoryConfirm.strings to Client/it.lproj/ClearHistoryConfirm.strings
  Writing Client/ClearPrivateData.strings to Client/it.lproj/ClearPrivateData.strings
  Writing Client/ErrorPages.strings to Client/it.lproj/ErrorPages.strings
  Writing Client/FindInPage.strings to Client/it.lproj/FindInPage.strings
  Writing Client/HistoryPanel.strings to Client/it.lproj/HistoryPanel.strings
  Writing Client/Info.plist to Client/it.lproj/InfoPlist.strings
  Writing Client/Intro.strings to Client/it.lproj/Intro.strings
  Writing Client/LightweightThemes.strings to Client/it.lproj/LightweightThemes.strings
  Writing Client/Localizable.strings to Client/it.lproj/Localizable.strings
  Writing Client/LoginManager.strings to Client/it.lproj/LoginManager.strings
  Writing Client/OnePasswordExtension.strings to Client/it.lproj/OnePasswordExtension.strings
  Writing Client/PrivateBrowsing.strings to Client/it.lproj/PrivateBrowsing.strings
  Writing Client/Search.strings to Client/it.lproj/Search.strings
  Writing Client/SendAnonymousUsageData.strings to Client/it.lproj/SendAnonymousUsageData.strings
  >>> Writing Client/SendTo.strings to Client/it.lproj/SendTo.strings
  >>> Writing Client/SendTo.strings to Extensions/SendTo/it.lproj/SendTo.strings
  Writing Extensions/SendTo/Info.plist to Extensions/SendTo/it.lproj/InfoPlist.strings
  Writing Extensions/ShareTo/ShareTo.strings to Extensions/ShareTo/it.lproj/ShareTo.strings
  Writing Extensions/ViewLater/Info.plist to Extensions/ViewLater/it.lproj/InfoPlist.strings
  Writing Client/Shared.strings to Client/it.lproj/Shared.strings
  Writing Client/Storage.strings to Client/it.lproj/Storage.strings
(Assignee)

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Confirming that the feature is now localized in build 2.0 201601181633
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.