Closed Bug 1234358 Opened 6 years ago Closed 3 years ago

[Aries] While launching browser in private mode background flickers with brown color

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(b2g-v2.5 unaffected, b2g-master affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.5 --- unaffected
b2g-master --- affected

People

(Reporter: MaxIvanov, Unassigned)

References

()

Details

(Keywords: regression, Whiteboard: [2.6-Daily-Testing][Spark] )

Background flickers brown color while a user launches browser in private mode

Repro Steps:
1) Update a Aries to 20151218153622
2) Press and hold home button 
3) Tap on private browsing icon
4) Observe background color

Actual:
Background flickers brown color

Expected:
Background color shouldn't be changed 

Environmental Variables:
Device: Aries 2.6
Build ID: 20151218153622
Gaia: d069027f9af6f835ef869f1f01b52339e5a3f423
Gecko: c5cb194cc9cb56d742fb3a7a826f0080b0404edc
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 46.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0

Repro frequency: (100 %)
See attached: (video clip, logcat)
https://youtu.be/B1YjPSSTaeg
This does not happen on Aries 2.5 and Flame 2.6
While launching browser in private mode background DOES NOT flicker with brown color

Environmental Variables:
Device: Aries 2.5
Build ID: 20151218184045
Gaia: eeed1451e0e48b63abe3199e4d6906adc2a762d2
Gecko: 766600655dfb1b67c380b9da4f4b19acb505a858
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 44.0 (2.5)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

Device: Flame 2.6
Build ID: 20151221030230
Gaia: 14aefb2519becfa32f31bcc3c9c995693421f19c
Gecko: e6ba2d4a2e4930bb359f90312ef6f1ebdc34c0ac
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 46.0a1 (2.6)
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Whiteboard: [2.6-Daily-Testing][Spark]
Correct variables for Aries 2.6:

Environmental Variables:
Device: Aries 2.6
Build ID: 20151221131907
Gaia: 14aefb2519becfa32f31bcc3c9c995693421f19c
Gecko: a8acaa9868df4aa8d801725cfa9ef744640fc402
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 46.0a1 (2.6)
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0
Seems minor so not nominating to block.
QA Whiteboard: [QAnalyst-Triage?]
Component: Gaia::Browser → Gaia::System::Window Mgmt
Flags: needinfo?(ktucker)
QA Contact: mmurrell
The Repro rate declines within about a day of the first broken build. Do to the low repro rate I'm unable to determine an accurate regression window. The first broken build has a repro rate of 16% (4/25).   

First Broken
Environmental Variables: Repros (4/25)
Device: Aries 2.6
BuildID: 20151117021715
Gaia: 54167ef91545c948e44098deb9f721210890eaf0
Gecko: 411c2abefef737dab05d0cf75bd9b59713395447
Gonk: 3af1ede0d0956cfbf9c549df7cd9a6807a9efdf2
Version: 45.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
The repro rate is too low to get a reliable window.
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado)
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 3 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.