Status

()

RESOLVED INCOMPLETE
3 years ago
2 years ago

People

(Reporter: kjhgfnbmbjgiyut, Unassigned)

Tracking

43 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [bugday-20151228], crash signature)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151216175450

Steps to reproduce:

quit the browser


Actual results:

it takes a few seconds and the monitor shows the rainbow loading icon like this 
https://www.google.com/?gws_rd=ssl#tbs=qdr:m&q=firefox+version+43+quitting+takes+time

Rebooting computer makes no differense.


Expected results:

If I remember correctly, quitting firefox takes less than one second at the previous version (ver 42) .
(Reporter)

Comment 1

3 years ago
the link was wrong. the icon is here.
https://upload.wikimedia.org/wikipedia/en/3/3d/WaitCursor-300p.gif
(Reporter)

Comment 2

3 years ago
With no plug-ins, no add-ons enabled.

It takes about 0.5 sec to finish quitting the browser when I open the browser with blank page and then immediately open this page of Bug 1234370 report from Bookmarks.

It takes about 6 sec to finish quitting the browser when I open the browser with blank page and then wait about 3 minites to open this page of Bug 1234370 report from Bookmarks. Fortunately, rainbow icon doesn't appear. But it often appears when I browse pages for dozens of minutes.
Thanks for the report.

Some thing you could try to narrow down the problem:
1) Test in a clean profile https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
2) Make sure you disabled all plugins in the new profile (such as flash and java)
3) Disable hardware acceleration https://support.mozilla.org/en-US/kb/troubleshoot-extensions-themes-to-fix-problems#w_turn-off-hardware-acceleration
4) Try to get a stack trace from hung Firefox on Mac OS X
https://developer.mozilla.org/en-US/docs/How_to_Report_a_Hung_Firefox

Please post back the results.
I should have mentioned that I can't reproduce the issue using the latest Nightly on Mac OS X 10.6.
(Reporter)

Comment 5

3 years ago
With the clean profile, it quits fast.
But after that, I modified prefs.js by overwriting it with the previous one, it starts delaying.
So I think the delay is mainly due to the prefs.js.


Here are the report of the hung Firefox after launching a blank page for 3 minutes which actually causes about 5 seconds delay to finish quitting Firefox :

AdapterDeviceID: 0x0867
AdapterVendorID: 0x10de
Add-ons: %7B972ce4c6-7e08-4474-a285-3208198ce6fd%7D:43.0.2
BuildID: 20151221130713
CrashTime: 1450979138
EMCheckCompatibility: true
FramePoisonBase: 7ffffffff0dea000
FramePoisonSize: 4096
InstallTime: 1450888452
Notes: AdapterVendorID: 0x10de, AdapterDeviceID: 0x0867
ProductID: {ec8030f7-c20a-464f-9b0e-13a3a9e97384}
ProductName: Firefox
ReleaseChannel: release
SafeMode: 0
SecondsSinceLastCrash: 6538
StartupTime: 1450978871
TelemetryEnvironment: {"build":{"applicationId":"{ec8030f7-c20a-464f-9b0e-13a3a9e97384}","applicationName":"Firefox","architecture":"x86-64","buildId":"20151221130713","version":"43.0.2","vendor":"Mozilla","platformVersion":"43.0.2","xpcomAbi":"x86_64-gcc3","hotfixVersion":"20130322.01","architecturesInBinary":"i386-x86_64"},"partner":{"distributionId":null,"distributionVersion":null,"partnerId":null,"distributor":null,"distributorChannel":null,"partnerNames":[]},"system":{"memoryMB":3840,"virtualMaxMB":null,"cpu":{"count":2,"cores":2,"vendor":"GenuineIntel","family":6,"model":23,"stepping":10,"l2cacheKB":6144,"l3cacheKB":null,"speedMHz":2660,"extensions":["hasMMX","hasSSE","hasSSE2","hasSSE3","hasSSSE3","hasSSE4_1"]},"os":{"name":"Darwin","version":"10.8.0","locale":"ja-JP"},"hdd":{"profile":{"model":null,"revision":null},"binary":{"model":null,"revision":null},"system":{"model":null,"revision":null}},"gfx":{"D2DEnabled":null,"DWriteEnabled":null,"adapters":[{"description":null,"vendorID":"0x10de","deviceID":"0x0867","subsysID":null,"RAM":null,"driver":null,"driverVersion":null,"driverDate":null,"GPUActive":true}],"monitors":[{"screenWidth":1920,"screenHeight":1200,"scale":1}],"features":{"compositor":"none"}}},"settings":{"addonCompatibilityCheckEnabled":true,"blocklistEnabled":true,"isDefaultBrowser":false,"e10sEnabled":false,"telemetryEnabled":false,"isInOptoutSample":false,"locale":"en-US","update":{"channel":"release","enabled":true,"autoDownload":false},"userPrefs":{"app.update.auto":false,"browser.cache.disk.capacity":358400,"browser.formfill.enable":false,"browser.newtabpage.enabled":false,"browser.newtabpage.enhanced":false,"browser.shell.checkDefaultBrowser":false,"browser.search.suggest.enabled":false,"browser.startup.homepage":"<user-set>","browser.startup.page":3,"layers.acceleration.disabled":true,"privacy.donottrackheader.enabled":true}},"profile":{"creationDate":16793},"addons":{"activeAddons":{},"theme":{"id":"{972ce4c6-7e08-4474-a285-3208198ce6fd}","blocklisted":false,"description":"The default theme.","name":"Default","userDisabled":false,"appDisabled":false,"version":"43.0.2","scope":4,"foreignInstall":false,"hasBinaryComponents":false,"installDay":16792,"updateDay":16792},"activePlugins":[],"activeGMPlugins":{"gmp-gmpopenh264":{"version":"1.5.1","userDisabled":true,"applyBackgroundUpdates":0}},"activeExperiment":{},"persona":null}}
Theme: classic/1.0
Throttleable: 1
Vendor: Mozilla
Version: 43.0.2
useragent_locale: en-US

This report also contains technical information about the state of the application when it crashed.
(Reporter)

Comment 6

3 years ago
FireFox ver.38 ESR, with my previous prefs.js of ver.43, seems work fine, I'll keep browsing with it for the time being.
(Reporter)

Comment 7

3 years ago
By the way, I found another bug for ver.43.

Now I have tested ver.43 and ver.38ESR, I can listen some music samples at Amazon, for example:
http://www.amazon.com/Hotel-California-Eagles/dp/B00DAKW7Q2/ref=tmm_msc_swatch_0?_encoding=UTF8&qid=&sr=

But I can't listen some other music samples at Amazon, for instance:
http://www.amazon.co.jp/%E9%AD%94%E5%A5%B3%E3%81%AE%E5%AE%85%E6%80%A5%E4%BE%BF-%E3%82%B5%E3%83%B3%E3%83%88%E3%83%A9%E9%9F%B3%E6%A5%BD%E9%9B%86-%E3%82%B5%E3%83%B3%E3%83%88%E3%83%A9/dp/samples/B0002RN9A4

On above site with ver.43, when I click one of the listen buttons, just blank window appears, no music. With ver.38ESR, the new window shows perfect contents and sample musics.

Maybe this should be another topics, but I'm not interested in amazon-firefox relations.

Comment 8

3 years ago
¡Hola!

Please follow https://developer.mozilla.org/en-US/docs/How_to_Report_a_Hung_Firefox anew and provide the resulting about:crashes link(s).

¡Gracias!
QA Whiteboard: [bugday-20151228]
Flags: needinfo?(kjhgfnbmbjgiyut)
Whiteboard: [bugday-20151228]
(In reply to kjhgfnbmbjgiyut from comment #6)
> FireFox ver.38 ESR, with my previous prefs.js of ver.43, seems work fine,
> I'll keep browsing with it for the time being.

Seems like some of the preferences active in Firefox 38 might cause the malfunction. Could you please compare the pref.js from Firefox 38 with the pref.js from a clean Firefox 43 install and post here the differences.

Most likely some ported preference is causing this.
Crash Signature: [@ mach_msg_trap ]
Flags: needinfo?(kjhgfnbmbjgiyut)
Comment hidden (typo)
(Reporter)

Comment 12

3 years ago
I've had a backup copy of version 40 in my PC, so I newly create a profile for that.
And overwrite the pref.js by the suspected ver.43 pref.js.
It worked fine and quitted immediately.
Then, I updated software from ver.40 to the latest ver.43.0.4.
It worked baaaaad, taking times to finish quitting FF.
So, appearently, updating to ver43 cause this trouble.

(It is possible that clean installing ver43 without updating will result in no trouble, but I think it is bad choice to do that, because if the updating-architecture in ver43 contains such trouble, next updating to ver.44 will keep containing that.)
Comment hidden (typo)
(Reporter)

Comment 14

3 years ago
OK, finally I've decided to close this topic.

Instead of solving this issue, I safely upgraded to the latest version of FF from scratch, and transfered data manually.
I used sync after upgrading to the latest version safely. But at first, all items were automatically synced, and it failed again, ie. the delay issue happened again! So, after many struggles, I restore it with the backup clean pref.js and synced only "history" and "add-ons", and worked perfectly, except some add-blocking add-on's preferences. So, I manually restore the add-blocking add-on's preference. In the final analysis, I found out sync "preferences" causes the delay problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Comment 15

3 years ago
I modify
 sync "preferences" causes the delay problem
to
 sync "preferences" inherit the delay problem


After all, I suspect the cause of this issue is updating-process of FF browser to ver.43. So I hope developpers take care about this.
(Reporter)

Updated

3 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Component: Untriaged → Sync
I don't think syncing your preferences could cause this shutdown hang, so I'm closing this as incomplete. Please let us know if you have any more information that might be able to help us diagnose this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago2 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.