Closed Bug 1234420 Opened 4 years ago Closed 2 years ago

Using a pinned website that has special colored skin could break skin color when navigating away from it

Categories

(Firefox OS Graveyard :: Gaia::System::Status bar, Utility tray, Notification, defect, P1)

ARM
Gonk (Firefox OS)
defect

Tracking

(b2g-v2.5 affected, b2g-master affected)

RESOLVED WONTFIX
Tracking Status
b2g-v2.5 --- affected
b2g-master --- affected

People

(Reporter: pcheng, Unassigned)

References

()

Details

(Keywords: polish, Whiteboard: [2.6-Daily-Testing] [spark] [systemsfe])

Attachments

(1 file)

Attached file logcat of issue
Description:
If user has a special theme colored website such as yahoo.com as their pinned website, navigating to another website via the forward button could cause browser to show wrong theme color.

STR:
1) Pin a special colored website to Home screen (I used yahoo.com which has purple colored theme)
2) Kill all current windows
3) Open the pinned website at step 1
4) Tap on search bar twice and access google.com on existing window
5) Once google is loaded, press back arrow button
6) On Yahoo.com, tap search bar once, and press the forward arrow button

Expected: Google website is accessed showing white browser skin

Actual: Google website is access showing black browser skin

Note:
This issue does not occur for non-pinned websites

Repro rate: 5/5

Video showing from step 3 onwards:
https://www.youtube.com/watch?v=0PE-Yc86bTo

Also attaching a logcat.

This occurs on:
Device: Aries 2.6
BuildID: 20151221131907
Gaia: 14aefb2519becfa32f31bcc3c9c995693421f19c
Gecko: a8acaa9868df4aa8d801725cfa9ef744640fc402
Gonk: a19052e4389c3ae2d8fc3e7a74a475401baacc56
Version: 46.0a1 (2.6) 
Firmware Version: D5803_23.1.A.1.28_NCB.ftf
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0

Device: Flame 2.6
BuildID: 20151221030230
Gaia: 14aefb2519becfa32f31bcc3c9c995693421f19c
Gecko: e6ba2d4a2e4930bb359f90312ef6f1ebdc34c0ac
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 46.0a1 (2.6) 
Firmware Version: v18Dv4
User Agent: Mozilla/5.0 (Mobile; rv:46.0) Gecko/46.0 Firefox/46.0
Flame 2.5 is also affected.

Device: Flame 2.5
BuildID: 20151218180935
Gaia: eeed1451e0e48b63abe3199e4d6906adc2a762d2
Gecko: 766600655dfb1b67c380b9da4f4b19acb505a858
Gonk: 205ac4204bbbb2098a8046444acba551ba5dc75a
Version: 44.0 (2.5) 
Firmware Version: v18D
User Agent: Mozilla/5.0 (Mobile; rv:44.0) Gecko/44.0 Firefox/44.0

-------

Not checking 2.2 since the ability to pin a website is not available on it.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(jmercado)
Whiteboard: [2.6-Daily-Testing] [spark] [systemsfe]
[Blocking Requested - why for this release]:

Theme problems have been blockers in the past so marking this as a blocker nomination.  Alison can you please take a look?
blocking-b2g: --- → 2.5?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(jmercado) → needinfo?(ashiue)
Not blocking since its mostly a visual regression and there is no serious user impact.
blocking-b2g: 2.5? → ---
Component: Gaia::Browser → Gaia::System::Status bar, Utility tray, Notification
Keywords: polish
Priority: -- → P1
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage+][COM=Pin the Web]
Flags: needinfo?(ashiue)
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.