TEST-UNEXPECTED-ERROR | test_about_window.py TestAboutWindow.test_open_window | NameError: global name 'By' is not defined

RESOLVED FIXED in Firefox 43

Status

Testing
Firefox UI Tests
P1
major
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: whimboo, Assigned: whimboo)

Tracking

({intermittent-failure})

43 Branch
mozilla44
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox43 fixed, firefox44 fixed)

Details

(Assignee)

Description

2 years ago
All of the release tests today were failing with the following failure:

https://treeherder.mozilla.org/logviewer.html#?job_id=125516&repo=mozilla-release

 19:47:57     INFO - TEST-UNEXPECTED-ERROR | test_about_window.py TestAboutWindow.test_open_window | NameError: global name 'By' is not defined

 19:47:57     INFO - 

 19:47:57     INFO - Traceback (most recent call last):

 19:47:57     INFO -   File "c:\jenkins\workspace\release-mozilla-release_functional\build\venv\lib\site-packages\marionette\marionette_test.py", line 344, in run

 19:47:57     INFO -     testMethod()

 19:47:57     INFO -   File "c:\jenkins\workspace\release-mozilla-release_functional\build\venv\lib\site-packages\firefox_puppeteer\tests\test_about_window.py", line 72, in test_open_window

 19:47:57     INFO -     about_window = self.browser.open_about_window(trigger=trigger)

 19:47:57     INFO -   File "c:\jenkins\workspace\release-mozilla-release_functional\build\venv\lib\site-packages\firefox_puppeteer\ui\browser\window.py", line 188, in open_about_window

 19:47:57     INFO -     return BaseWindow.open_window(self, callback, AboutWindow)

 19:47:57     INFO -   File "c:\jenkins\workspace\release-mozilla-release_functional\build\venv\lib\site-packages\firefox_puppeteer\ui\windows.py", line 342, in open_window

 19:47:57     INFO -     callback(self)

 19:47:57     INFO -   File "c:\jenkins\workspace\release-mozilla-release_functional\build\venv\lib\site-packages\firefox_puppeteer\ui\browser\window.py", line 180, in callback

 19:47:57     INFO -     trigger(win)

 19:47:57     INFO -   File "c:\jenkins\workspace\release-mozilla-release_functional\build\venv\lib\site-packages\firefox_puppeteer\tests\test_about_window.py", line 63, in opener

 19:47:57     INFO -     menu = win.marionette.find_element(By.ID, 'aboutName'
(Assignee)

Comment 1

2 years ago
This seems to be a regression from my patch on bug 1232331:

https://github.com/mozilla/firefox-ui-tests/commit/4afd18763bdcde5f8b1c241e5b9a83048d99e15d#diff-cd5228f2e4e7b97409363f20dbe7a8bdL5

Main problem is that we got the commit from bug 1121710 not backported to beta and release:
https://github.com/mozilla/firefox-ui-tests/commit/b1ea646a38f8373364aceac895083990bdff7e80

I should fix this via bug 1232331 by adjusting the backports.
Depends on: 1232331
(Assignee)

Updated

2 years ago
Keywords: intermittent-failure
(Assignee)

Comment 2

2 years ago
A bustage fix has been landed on both mozilla-beta and mozilla-release branches. So this issue is fixed now:

https://treeherder.mozilla.org/logviewer.html#?job_id=125517&repo=mozilla-release
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox43: --- → fixed
status-firefox44: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 44
Version: Firefox 45 → Firefox 43

Comment 3

2 years ago
111 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-release: 111

Platform breakdown:
* windows8-64: 18
* windows7-64: 18
* windowsxp: 9
* windows8-32: 9
* windows7-32: 9
* osx-10-9: 8
* osx-10-6: 8
* osx-10-11: 8
* osx-10-10: 8
* linux64: 8
* linux32: 8

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1234495&startday=2015-12-22&endday=2015-12-22&tree=all

Comment 4

2 years ago
117 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-release: 117

Platform breakdown:
* windows8-64: 18
* windows7-64: 18
* windowsxp: 9
* windows8-32: 9
* windows7-32: 9
* osx-10-9: 9
* osx-10-6: 9
* osx-10-11: 9
* osx-10-10: 9
* linux64: 9
* linux32: 9

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1234495&startday=2015-12-21&endday=2015-12-27&tree=all
Product: Mozilla QA → Testing
You need to log in before you can comment on or make changes to this bug.