Closed Bug 123454 Opened 19 years ago Closed 15 years ago

Notification mail is sent to disabled users

Categories

(Bugzilla :: Email Notifications, defect)

2.15
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: tree, Unassigned)

References

Details

Attachments

(1 file)

When reporting a change to a bug reported by a now disabled user, Bugzilla 
still sends mail to that disabled user. Unfortunately this disabled user no 
longer has an email account at that address, and the message bounces.
Adding my favorite reviewers. This patch fixes my problem. Myk, mpt has reported
to me that this happens on b.m.o - can you confirm?

Is-this-a-dupe-ly yours, Kiko
Comment on attachment 67920 [details] [diff] [review]
Proposed patch to processmail to filter disabled accounts

I don't know processmail very much and it's scary to look at, but this patch
fixes the problem, has no indent, clarity or tab problems, and does the right
thing AFAICS.

r=kiko
Attachment #67920 - Flags: review+
Comment on attachment 67920 [details] [diff] [review]
Proposed patch to processmail to filter disabled accounts

r=ddk (ditto)
Attachment #67920 - Flags: review+
Keywords: patch, review
Target Milestone: --- → Bugzilla 2.16
Comment on attachment 67920 [details] [diff] [review]
Proposed patch to processmail to filter disabled accounts

I object.

This is an advertised feature.	If we're going to completely disable email for
disabled accounts then we need to find some way to specify an account which is
not allowed to log in but can still receive email.  Many installations use this
hack to set up a mailing list as a default assignee, but prevent anyone who
reads that mailing list from being able to log in and make changes as the
mailing list address and/or reset the password.
Attachment #67920 - Flags: review-
Attachment #67920 - Flags: review+
Maybe the bug mpt has noticed is another one then.
Given the latest round of comments, and a discussion on IRC earlier today, I'm 
going to revisit this and add a new option.

Moving this to 2.18 because fixing this right is more than likely going to
involve a schema change (or at least having the preference table in), and we're
too late in the game to do that in 2.16.
Target Milestone: Bugzilla 2.16 → Bugzilla 2.18
Bug #100953 might be the solution to this.
Changing default owner of Email Notifications component to JayPee, a.k.a.
J. Paul Reed (preed@sigkill.com).  Jake will be offline for a few months.
Assignee: jake → preed
Keywords: review
Don't fix this yet. This "feature" means that people can use mailing lists as QA
contacts without people logging in as that user; i.e., it makes it possible for
a bug to have multiple assignees or QA contacts.

If you fix this loophole, you need to find another way to enable that
functionality first.

Gerv
Target Milestone: Bugzilla 2.18 → ---
This should not be done globally as noted in comment 11.
data/nomail stinks and should go away (or be used only for nomail regexps).

This should be done by having an email pref visible both on the user's prefs
page AND the editusers page that determines if mail should be supressed
altogether. (or perhaps if mail should stay enabled even if the account is
disabled?)

Depends on: emailprefs
Target Milestone: --- → Bugzilla 2.20
Here's a better way to do this, IMO:

Since we already have a "nomail" file (data/nomail), how about a checkbox on the
user page (next to the Disable Text box) to suppress mail to that user as well? 

This check box should add the user to the "nomail" mail if checked, and remove
the user from the nomail file if unchecked.  When displaying the page, show the
box as checked if the address is in the nomail file.

Let me see if I can drum up a patch..
Fiddling with data/nomail is a bad way.  It should just be another field in the
profiles table or a global emailpref that can be configured by the user OR the
administrator.

Gerv - does your emailprefs design already cover this?
The new emailprefs stuff I have been/am working on doesn't send mail to disabled
users.

Gerv
oh good, so we won't be able to setup a mailinglist which is subscribed to bugs
but for which people can't reset the password.

can we please not break existing functionality?
The appropriate solution is an independent checkbox.  All four combinations of
P({DISABLED,NOMAIL}) are acceptable.  See bug #100953 for this.
Actually I've changed my mind on this somewhat, since what I described above
will not be sufficient for bug #148079.  What we need is to distinguish mailing
lists, and prevent logins for them without being disabled.  Then we can unify
disabling and nomail.

The trick will be transitioning to this scheme.  A release note might be required.
Status: NEW → ASSIGNED
*** Bug 283517 has been marked as a duplicate of this bug. ***
As preed is no longer actively working on Bugzilla (from what I know), I somehow
doubt that this bug will make it in for 2.20. :-) If I'm wrong, feel free to
take it back and re-target it. :-)
Assignee: preed → email-notifications
Status: ASSIGNED → NEW
Target Milestone: Bugzilla 2.20 → ---
Alexandre, don't you have a patch for this?
QA Contact: mattyt-bugzilla → default-qa
Depends on: 100953
Whiteboard: [blocker will fix]
I'm working on a patch to bug 100953 now, so people will be able to disable bugmail for users, independently of disabling their ability to log in.

If this bug isn't resolved as WONTFIX/DUPLICATE because of bug 100953 landing, I could see a global preference along the lines of "Disable all email for users with bugmail disabled" or "Disable all email for users with logins disabled".
OK, so bug 100953 has landed.  Question is now: What do we do with this bug, if anything at all?  I can think of a couple possibilities:

* RESOLVE/WONTFIX
* RESOLVE/DUPLICATE of 100953
* Create a contrib script admins can run, which would disable email for every user in their DB who is disabled (probably cleaner than a button in a web page).
* A new boolean parameter, "Automatically disable bugmail for disabled users".  Would this make the new checkbox unavailable, automatically checking it when disable text is set?  Should the vice-versa effect be implemented?  When happens when this is turned on and you have users who are already disabled but can get bugmail, are they changed?

I'd prefer the first option, or the third.
So in CVS Bugzilla, you can independently set whether an account is disabled and whether it receives mail? Sounds like we're in the right place. So this is now a WONTFIX - because the fact that an account is disabled is no longer tied to its mail state.

Nice work, Karl :-)

Gerv
Nothing prevents you from disabling notifications for disabled accounts. You can now use the UI for that (when you enter some text in the disabledtext field, you can also check the enable/disable bugmail). WFM
Status: NEW → RESOLVED
Closed: 15 years ago
Resolution: --- → WORKSFORME
Whiteboard: [blocker will fix]
*** Bug 363818 has been marked as a duplicate of this bug. ***
Duplicate of this bug: 412053
Duplicate of this bug: 421045
Duplicate of this bug: 662899
You need to log in before you can comment on or make changes to this bug.