easily compile/build Firefox on any system

RESOLVED INVALID

Status

--
enhancement
RESOLVED INVALID
3 years ago
20 days ago

People

(Reporter: pedrogfrancisco, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [DUPEME])

(Reporter)

Description

3 years ago
This bug is orthogonal to the reproducible builds bug #885777 .

It should be easy to build Firefox on any system.

With the proliferation of so many open source programs, the easiest way to determine if "open source" status would be to build it.

For example:
CyanogenMod- it is open source, but it requires me to extract binary blobs from my phone before I can build it on my computer.
Chromium- it is open source, but if I'm going to get a good version, probably it is better to install Chrome.

My idea would be to use something like https://techbase.kde.org/Getting_Started/Build/Windows/emerge to set up the base build system.


An additional advantage would be reducing the jump to developer- the source would be available much easily.


On Linux my requirement is satisfied as long as I use Gentoo, so not sure if it really is an issue there.

Updated

3 years ago
Severity: minor → enhancement
Component: General → Build Config
Whiteboard: [DUPEME]

Comment 1

a year ago
This bug is too generic to be useful. We're doing our best to make it easy to compile Firefox, but of course building it on "any system" is a generic "good thing" that isn't actually fixable (also because there are some systems where new versions of Firefox will never build, like on old OSes, machines without enough RAM/CPU, etc.). As a result, I'm going to close this bug out.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → INVALID
Component: Build Config → General
Product: Firefox → Firefox Build System
You need to log in before you can comment on or make changes to this bug.