Sync produces unexpected error

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: hangfirew8, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8701309 [details]
FirefoxUnexpectedError.png

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151216114437

Steps to reproduce:

Restarted Safe Mode
Firefox Reset
Password Reset
Moved aside .mozilla folder/restart


Actual results:

Firefox 43.0 on Linux Mint (latest) Sync always produces an "Unexpected error" after "Working" when signing in.

I used Sync across a Mac, 2 Windows machines and 3-4 Linux systems. I suspect a "bad character" from the Mac or Windows is breaking the Linux sync.


Expected results:

Sync should occur.
(Reporter)

Updated

3 years ago
Component: Untriaged → Sync
OS: Unspecified → Linux
Hardware: Unspecified → x86_64
This is an "expected error" while logging in via about:accounts
Component: Sync → Server: Firefox Accounts
Product: Firefox → Cloud Services
Version: 43 Branch → unspecified
(In reply to Mark Hammond [:markh] from comment #1)
> This is an "expected error" while logging in via about:accounts

doh - "unexpected error"
(Reporter)

Comment 3

3 years ago
I'm not sure what your point is. It occurs when I'm logging in from Preferences->Sync->Sign In. 

I just tried it from about:accounts. Same thing, Working, then Unexpected Error.
Shane, any ideas here (or ideas about a better person to ask)?
Flags: needinfo?(stomlinson)
(In reply to hangfirew8 from comment #0)
> Created attachment 8701309 [details]
> FirefoxUnexpectedError.png
> 
> User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:43.0) Gecko/20100101
> Firefox/43.0
> Build ID: 20151216114437
> 
> Steps to reproduce:
> 
> Restarted Safe Mode
> Firefox Reset
> Password Reset
> Moved aside .mozilla folder/restart
> 
> 
> Actual results:
> 
> Firefox 43.0 on Linux Mint (latest) Sync always produces an "Unexpected
> error" after "Working" when signing in.
> 
> I used Sync across a Mac, 2 Windows machines and 3-4 Linux systems. I
> suspect a "bad character" from the Mac or Windows is breaking the Linux sync.
> 
> 
> Expected results:
> 
> Sync should occur.

... 

> "I suspect a "bad character" from the Mac or Windows is breaking the Linux sync." 

Why do you say that a bad character is to blame here?  

Can you sign in via https://accounts.firefox.com on that machine?
Flags: needinfo?(hangfirew8)
> (In reply to hangfirew8 from comment #0)
> Created attachment 8701309 [details]
> FirefoxUnexpectedError.png
> 
> User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:43.0) Gecko/20100101
> Firefox/43.0
> Build ID: 20151216114437
> 
> Steps to reproduce:
> 
> Restarted Safe Mode
> Firefox Reset
> Password Reset
> Moved aside .mozilla folder/restart
> 
> 
> Actual results:
> 
> Firefox 43.0 on Linux Mint (latest) Sync always produces an "Unexpected
> error" after "Working" when signing in.
> 
> I used Sync across a Mac, 2 Windows machines and 3-4 Linux systems. I
> suspect a "bad character" from the Mac or Windows is breaking the Linux sync.
> 
> 
> Expected results:
> 
> Sync should occur.

Thanks, can you be more explicit about the steps?

> Restarted Safe Mode
> Firefox Reset
> Password Reset
> Moved aside .mozilla folder/restart

Did you previously sign in to Sync using this browser? Does FxA work if you start in "normal" (not Safe) mode? Password Reset is a Firefox Accounts password reset? Did you initiate the reset from Linux Mint or another OS? Did you verify your email after initiating the password reset?

> Moved aside .mozilla folder

Forgive my naivety, on which machine did you move the .mozilla folder, for what reason, and what effect does it have?

Finally, when did you try signing in to Sync, after the listed steps?
Flags: needinfo?(stomlinson)
(In reply to Shane Tomlinson [:stomlinson] from comment #6)
> > Moved aside .mozilla folder
> 
> Forgive my naivety, on which machine did you move the .mozilla folder, for
> what reason, and what effect does it have?

I believe this is where the profiles are stored on Linux - so I assume this had the result of deleting the profile, which Firefox should recreate on the next start. However, that would make all the other steps somewhat pointless - there's no need to reset Firefox and do the safe-mode dance if we are just deleting the profile later.

hangfire, can you please see comment 5 and comment 6 and provide some additional info?
(Reporter)

Comment 8

3 years ago
Hey guys, thanks for taking a look at this.

Vlad: Why do you say that a bad character is to blame here?

Just guessing. This was the case on the old Sync regime when a Linux FF to Linux FF fell apart. I got determined and did a binary compare (halving bookmarks repeatedly and seeing which half failed or succeeded.) Finally I got down to one bookmark that had a bunch of mojibake in it. I removed that from each FF's bookmarks and I could sync again. But, that was years ago, and I don't have that kind of time right now. I took a quick look and saw nothing obviously corrupt.

Vlad: Yes, I can log into https://accounts.firefox.com , from the Mac anyway. OK I just brought up a FF on a fresh 14.04LTS VM and I could log in just fine.

Shane: Did you previously sign in to Sync using this browser? Yes. I use two of the browsers daily, sharing bookmarks via Sync, when I noticed that the Linux browser was no longer syncing. I tried another Linux Firefox and it had the same problem. From the sequence of events I suspect that the Mac Firefox was the last to write bookmarks, and indeed it continues to Sync.

>Does FxA work if you start in "normal" (not Safe) mode? Not sure what FxA is. If you mean Sync, the answer is No.

Password Reset is a Firefox Accounts password reset? Yes.

>Did you initiate the reset from Linux Mint or another OS? Mint, it affected the Mac, I had to change it there, too. Same result, Linux FF still couldn't Sync, Mac FF could.

>Did you verify your email after initiating the password reset? 
Not sure what you mean by "verify". It's been a long time since I verified this account, right after Mozilla changed the way Sync accounts work. This time, I went through the email reset process just fine. 

>> Moved aside .mozilla folder

>Forgive my naivety, on which machine did you move the .mozilla folder, for what reason, and what effect does it have?

On Linux. No effect, other than the obvious, losing all my settings.

>Finally, when did you try signing in to Sync, after the listed steps?

Same thing. Mac OK, Linux fails.
(Reporter)

Updated

3 years ago
Flags: needinfo?(hangfirew8)
(Reporter)

Comment 9

3 years ago
Hmm. Without changing anything more except updates to Firefox, Sync has started working again. I last tried a little more than a week ago and it still didn't work.

I'm not too thrilled with the results. At work I reorganized all my work related bookmarks. Now they show up in both the old places and the new. Now I have to sort this mess out. Sync ain't Git.
(Reporter)

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.