Mozilla holds focus for extended periods of time

RESOLVED DUPLICATE of bug 114283

Status

()

Core
Event Handling
RESOLVED DUPLICATE of bug 114283
17 years ago
16 years ago

People

(Reporter: Joseph Zbiciak, Assigned: joki (gone))

Tracking

Trunk
Sun
Solaris
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
(The following is based on the bug-helper form that doesn't work for me for
some reason.  Also, my user-agent string is mis-reported as "Mozilla/3.01Gold
(Macintosh; I; 68K)", probably because I'm using Junkbuster.  My build ID is
2001112114.)

PRODUCT
        Browser and Composer

COMPONENT
        Event handling

PLATFORM
        Sun

OPERATING SYSTEM
        Solaris


BUILD ID
        2001112114

URL
        n/a

SUMMARY
        Mozilla holds focus for extended periods of time

DESCRIPTION
        When I start a page loading (say, by clicking on a link), 
        Mozilla "locks" my desktop by not releasing the focus until the
        remote host is contacted and the page starts downloading.  For
        instance, if I right-click and "Open [page] in New Tab", and
        then try to change virtual desktops with [Alt]-[FunctionKey] (I
        use olvwm), I am unable to do so until the remote server has
        been contacted.  This can take up to 30 seconds sometimes, and
        that's very annoying.  There are other bits of flakiness with
        the focus as well which I haven't been able to isolate beyond
        being caused by Mozilla.

        Some details of my configuration:
  
        OS (uname -a):  SunOS caffeine 5.8 Generic_108528-06 sun4u sparc
        Window manager:  OLVWM  (OpenLook Virtual Window Manager), 
                         patched to support True-Color visuals, and
                         redraw during resize (custom hack)

REPRODUCIBILITY
        Every time.

STEPS TO REPRODUCE
        1. Start a page loading
        2. Try to shift focus to another window or change virtual desktops.

ACTUAL RESULTS
        Mozilla very slow to release focus, and in fact seems to wait 
        until the remote host is contacted.  Indeed, I can sometimes 
        manage to switch virtual desktops during a gap between network
        connections, but then I'm left with a desktop sans window
        borders for another 30 seconds as Moz seems to re-grab focus
        (or *something* -- not sure -- I'm no X guru, not even close).

EXPECTED RESULTS 
        I can switch between windows or virt desktops with little or no 
        headaches.  Moz should gracefully release focus whenever such
        release is requested.

SEVERITY
        Normal

Comment 1

17 years ago
probably dup of Bug 114283.
Try newer mozilla.

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 114283 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Updated

16 years ago
QA Contact: madhur → rakeshmishra

Updated

16 years ago
QA Contact: rakeshmishra → trix
You need to log in before you can comment on or make changes to this bug.