issues with 3D transforms & clicks at vulturiceye.com

RESOLVED FIXED in Firefox 46

Status

()

RESOLVED FIXED
3 years ago
2 years ago

People

(Reporter: cmills, Unassigned)

Tracking

({regression})

46 Branch
mozilla46
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox43 unaffected, firefox44 unaffected, firefox45 unaffected, firefox46 fixed)

Details

I'm having trouble getting my band's website working in Firefox:

http://vulturiceye.com/

The below issues are problems in Firefox; the site works absolutely fine in Chrome, Opera, Safari and MS Edge (but not IE 9/10/11, as they don't support preserve-3D, but that's another story.)

1. When you click a tile, it should rotate around to show backface content. When clicked again, a tile should rotate around again to show the frontface.

* In the Firefox current release version, this works, but the animation is not smooth; it jerks instead.
* In Firefox Nightly, the animation is smooth, but most tiles don't rotate back around again when a tile is clicked for a second time. It seems like something to do with the click event not being propagated to the front face's children.

2. The center right and bottom left tile backfaces have a play icon on them that, when clicked, should play a video.

* In the Firefox current release version, this works ok.
* In Firefox Nightly, the icon is just not clickable at all, so the videos can't be played. I can't work out why.

Comment 1

3 years ago
[Tracking Requested - why for this release]:
status-firefox44: --- → unaffected
status-firefox45: --- → affected
status-firefox46: --- → affected
tracking-firefox45: --- → ?
tracking-firefox46: --- → ?

Updated

3 years ago
Blocks: 1168263
Keywords: regression
Maybe duplicate of one of the other regressions from bug 1168263, but if not, probably worth looking into.
Flags: needinfo?(matt.woodrow)
(In reply to Chris Mills (Mozilla, MDN editor) [:cmills] from comment #0)
> * In Firefox Nightly, the animation is smooth, but most tiles don't rotate
> back around again when a tile is clicked for a second time. It seems like
> something to do with the click event not being propagated to the front
> face's children.

This issue (click events w/ 3d transformed stuff) sounds more like a duplicate of bug 1231207 "Not able to click preserve-3d link", which is a duplicate of bug 1226904, which has a patch that will hopefully be landing soon.
(In reply to Chris Mills (Mozilla, MDN editor) [:cmills] from comment #0)
> * In Firefox Nightly, the icon is just not clickable at all, so the videos
> can't be played. I can't work out why.

(This second issue also sounds like the bugs mentioned in comment 3.)

Thanks for testing Nightly & for filing the bug! With any luck, this will be fixed soon by bug 1226904.
(In reply to Daniel Holbert [:dholbert] from comment #4)
> (In reply to Chris Mills (Mozilla, MDN editor) [:cmills] from comment #0)
> > * In Firefox Nightly, the icon is just not clickable at all, so the videos
> > can't be played. I can't work out why.
> 
> (This second issue also sounds like the bugs mentioned in comment 3.)
> 
> Thanks for testing Nightly & for filing the bug! With any luck, this will be
> fixed soon by bug 1226904.

I test it all the time ;-) Thanks for the details, Daniel/all.
Following up here:
 * Good news: the tile-flipping now works for me in Nightly, so that part was indeed a dupe of bug 1226904.
 * Bad news: the video icon on the (flipped) backside of the lower-left tile is still unclickable.
 * Good news: that video icon becomes clickable if I apply the patch on bug 1230693.

So, this depends on bug 1226904 and bug 1230693, and can be resolved as FIXED once both of those bugs are fixed, I suppose. (or duped to one of them)
Depends on: 1226904, 1230693
Summary: CSS animation- and 3D transform-related issues → issues with 3D transforms & clicks at vulturiceye.com
[Clearing tracking flags/requests -- we can manage those on the bugs where the implementation work is being done.]
status-firefox44: unaffected → ---
status-firefox45: affected → ---
status-firefox46: affected → ---
tracking-firefox45: ? → ---
tracking-firefox46: ? → ---

Updated

3 years ago
Depends on: 1236228
No longer depends on: 1236228
The dependencies here are fixed now, so this should be retested and closed if appropriate.
The tile-flipping behaviour is now fixed in Nightly - awesome work!

However, the video links still don't seem to work.
Ah, it looks like bug 1230693 didn't make it to the Jan 11 nightly. Hopefully it should be fixed in tomorrow's build.
I can confirm that this is fixed in builds that include bug 1230693 on both Linux and Windows (and I could reproduce the video playback issues in builds that don't have it).
Status: NEW → RESOLVED
Last Resolved: 3 years ago
status-firefox43: --- → unaffected
status-firefox44: --- → unaffected
status-firefox45: --- → affected
status-firefox46: --- → fixed
Flags: needinfo?(matt.woodrow)
Resolution: --- → FIXED
Target Milestone: --- → mozilla46
I've just tested it again, and both issues now appear to be fixed. Woo hoo!

Thanks all.
The change that caused this regression was backed out from Firefox 45. A current Developer Edition build should now work correctly, or you can wait until 45 goes to Beta some time next week.

https://hg.mozilla.org/releases/mozilla-aurora/rev/64ec448f156d
status-firefox45: affected → unaffected
Version: unspecified → 46 Branch
You need to log in before you can comment on or make changes to this bug.