If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Flame] Very irritating unnecessary touch events

RESOLVED WONTFIX

Status

Firefox OS
Gaia::System
--
major
RESOLVED WONTFIX
2 years ago
2 years ago

People

(Reporter: shine, Unassigned)

Tracking

({feature, foxfood})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: flame-only)

Attachments

(1 attachment)

(Reporter)

Description

2 years ago
Flame has been sending very irritating unnecessary touch events occasionally. It is unpredictable. When it comes, the device is totally useless. You have to physically fight with the device to get things done.

It's not just me, some of my friends from my regional community have been facing the same issue until they switched over.


Bug 1053659 is related / similar but has been RESOLVED FIXED by sending replacement devices. That was in the center of the screen alone. I've had it in many points. I thought this was due to my use of the device (I use it extensively since it is my primary device), but I confirmed it was a bug when my friends reported that they were facing the same issues for months. I strongly believe that this is not a device issue and could be a Gaia issue because the touch events are random and affects more than one device.

The bug disappears after an OTA or a restart (for a while), but it comes back again. I've flashed different builds to see whether it was a build issue. Everything under 2.0 doesn't have this issue. Some builds of 2.2 is fine as well. Some other builds of 2.2 and up have failed me. The most disturbing part is that I can't predict when the bug happens or when it'll disappear. Sometimes this happens when I need to use my phone in an emergency. It hurts when people ask me to get a better phone and that Firefox OS sucks. :frowning:

I'm on the nightly channel (build ID : 20151023030241). The one that is supposed to pass the smoke tests and be the most stable for the flame.

I could be wrong. Or maybe I'm judging too much. I really wanted to use Firefox OS as my primary device. Even if I get a new device, I'll make sure it is compatible with Firefox OS (has a well-maintained port).

I've reached to a point that I've finally given up and decided to get an Android (though I really don't want to).

PS : let me know if you need logs or more info. I'd be happy to provide them.

Comment 1

2 years ago
A video of the issue would help I think. Did you also try with the lastest builds? switch to nightly-latest, as 20151023030241 is very old now!

Comment 2

2 years ago
I think you are using the version between 2.0 and 2.2.

Comment 3

2 years ago
i faced this issue in 2.1 at that time i made a hard reset to the phone

Updated

2 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 4

2 years ago
Created attachment 8701423 [details]
WP_20151223_003.m4v

Video of the bug irritating general use.
(Reporter)

Comment 5

2 years ago
(In reply to Rigin Oommen from comment #2)
> I think you are using the version between 2.0 and 2.2.

I'm on the latest build in the nightly channel. The version is 2.5 now.

Comment 6

2 years ago
(In reply to Shine Nelson [:shine] from comment #4)
> Created attachment 8701423 [details]
> WP_20151223_003.m4v
> 
> Video of the bug irritating general use.

It seems to be funny(ചാത്തൻ) behaviour. can you try to restore the factory settings instead of hard reset

Comment 7

2 years ago
This same issue has happen to my flame device and my friend device too. I do all the process told by rigin but it will not solve the issue..
Severity: normal → major

Updated

2 years ago
Component: Gaia → Gaia::System

Updated

2 years ago
Keywords: feature, foxfood
Shine: Can you please make sure to update to the latest Base image and report back as to whether you are still seeing this bug? In one of the discourse threads I saw, you mentioned you were still using V3.
Whiteboard: flame-only
(Reporter)

Comment 9

2 years ago
(In reply to Marcia Knous [:marcia - use ni] from comment #8)
> Shine: Can you please make sure to update to the latest Base image and
> report back as to whether you are still seeing this bug? In one of the
> discourse threads I saw, you mentioned you were still using V3.

I flashed the latest base image (v4) last night and updated to the nightly-latest build 20151229030208. The issue still persists. I guess it's a hardware issue then.

I'm happy that I was able to use the device as my primary device for a good 6-8 months.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WONTFIX

Comment 10

2 years ago
(In reply to Shine Nelson [:shine] from comment #9)
> (In reply to Marcia Knous [:marcia - use ni] from comment #8)
> > Shine: Can you please make sure to update to the latest Base image and
> > report back as to whether you are still seeing this bug? In one of the
> > discourse threads I saw, you mentioned you were still using V3.
> 
> I flashed the latest base image (v4) last night and updated to the
> nightly-latest build 20151229030208. The issue still persists. I guess it's
> a hardware issue then.
> 
> I'm happy that I was able to use the device as my primary device for a good
> 6-8 months.

can you flash with some lower version of Firefox OS like 1.3. i dont think its a hardware issue

Updated

2 years ago
Flags: needinfo?(radioactive.life)
(Reporter)

Comment 11

2 years ago
(In reply to Rigin Oommen from comment #10)
> can you flash with some lower version of Firefox OS like 1.3. i dont think
> its a hardware issue

So did I. I'm now convinced that it is indeed a hardware issue. I'm going to try the latest stable (v2.0) anyhow. I don't know where I can find lower versions. Please point me to some 1.x builds if possible.
Flags: needinfo?(radioactive.life)
(Reporter)

Comment 12

2 years ago
Oh nevermind the lower versions. I found it in the same MDN page. I just didn't scroll enough. ;-)
(Reporter)

Comment 13

2 years ago
Confirmed with v2.0 and v1.3. Both versions have the same issues. My flame is dead! :'(
You need to log in before you can comment on or make changes to this bug.