Not able to attach document in the bugs

RESOLVED WORKSFORME

Status

()

Bugzilla
Attachments & Requests
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: Antoine, Unassigned)

Tracking

4.4.6

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36

Steps to reproduce:

Trying to attach a file in Bugzilla. 

(File size limit: 10240 KB)

Size of the Document is 6 MB. 

My CGI file details 
package CGI;
require 5.008001;
use if $] >= 5.019, 'deprecate';
use Carp 'croak';

$CGI::VERSION='4.25';




Actual results:

Browser Error as given bellow;
Software error:

CGI.pm: Server closed socket during multipart read (client aborted?).

Apache Error Log as 

[Mon Dec 21 04:03:28 2015] [error] [client ] [Mon Dec 21 04:03:12 2015] attachment.cgi: Wide character in print at /usr/local/share/perl5/CGI.pm line 3411., referer: https://xxx/attachment.cgi?bugid=402990&action=enter
[Mon Dec 21 04:03:28 2015] [error] [client ] [Mon Dec 21 04:03:12 2015] attachment.cgi: Wide character in print at /usr/local/share/perl5/CGI.pm line 3411., referer: https://xxx/attachment.cgi?bugid=402990&action=enter
[Mon Dec 21 04:03:28 2015] [error] [client ] [Mon Dec 21 04:03:12 2015] attachment.cgi: Wide character in print at /usr/local/share/perl5/CGI.pm line 3411., referer: https://xxx/attachment.cgi?bugid=402990&action=enter
[Mon Dec 21 04:03:28 2015] [error] [client ] [Mon Dec 21 04:03:12 2015] attachment.cgi: Wide character in print at /usr/local/share/perl5/CGI.pm line 3411., referer: https://xxx/attachment.cgi?bugid=402990&action=enter
[Mon Dec 21 04:03:28 2015] [error] [client ] [Mon Dec 21 04:03:12 2015] attachment.cgi: Wide character in print at /usr/local/share/perl5/CGI.pm line 3411., referer: https://xxx/attachment.cgi?bugid=402990&action=enter
[Mon Dec 21 04:03:28 2015] [error] [client ] [Mon Dec 21 04:03:12 2015] attachment.cgi: Wide character in print at /usr/local/share/perl5/CGI.pm line 3411., referer: https://xxx/attachment.cgi?bugid=402990&action=enter
[Mon Dec 21 04:03:28 2015] [error] [client ] [Mon Dec 21 04:03:12 2015] attachment.cgi: Wide character in print at /usr/local/share/perl5/CGI.pm line 3411., referer: https://xxx/attachment.cgi?bugid=402990&action=enter
[Mon Dec 21 04:03:28 2015] [error] [client ] [Mon Dec 21 04:03:12 2015] attachment.cgi: Wide character in print at /usr/local/share/perl5/CGI.pm line 3411., referer: https://xxx/attachment.cgi?bugid=402990&action=enter
[Mon Dec 21 04:03:28 2015] [error] [client ] [Mon Dec 21 04:03:12 2015] attachment.cgi: Wide character in print at /usr/local/share/perl5/CGI.pm line 3411., referer: https://xxx/attachment.cgi?bugid=402990&action=enter
[Mon Dec 21 04:03:28 2015] [error] [client ] [Mon Dec 21 04:03:12 2015] attachment.cgi: Wide character in print at /usr/local/share/perl5/CGI.pm line 3411., referer: https://xxx/attachment.cgi?bugid=402990&action=enter



Expected results:

Attachment should attach in the bug

Comment 1

2 years ago
Using the same CGI version (4.25), file size limit (10240 KB) and uploading a 6.41 MB MP4 file, the upload completed without any problem. And the attached file integrity is correct; I could play the MP4 file without any problem.

The line mentioned in your error log is:

  print $filehandle $data if ($self->{'use_tempfile'});

No idea why it complained here. It doesn't in my case (as expected). Are you sure your installation has UTF8 enabled?
Assignee: general → attach-and-request
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Component: Bugzilla-General → Attachments & Requests
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

2 years ago
In my installation I have enabled UTF8 in params file and executed the checksetup.pl file. It executed successfully.  

Uploading process is performing up to 60% and then it is not proceeding further. Please provide your inputs.
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
(In reply to Antoine from comment #2)
> In my installation I have enabled UTF8 in params file and executed the
> checksetup.pl file. It executed successfully.  
> 
> Uploading process is performing up to 60% and then it is not proceeding
> further. Please provide your inputs.

Copy and paste the output of perl -V please.
Flags: needinfo?(antovinraj)
(Reporter)

Comment 4

2 years ago
Summary of my perl5 (revision 5 version 10 subversion 1) configuration:

  Platform:
    osname=linux, osvers=2.6.18-308.1.1.el5, archname=x86_64-linux-thread-multi
    uname='linux x86-001.build.bos.redhat.com 2.6.18-308.1.1.el5 #1 smp fri feb 17 16:51:01 est 2012 x86_64 x86_64 x86_64 gnulinux '
    config_args='-des -Doptimize=-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic -DDEBUGGING=-g -Dversion=5.10.1 -Dmyhostname=localhost -Dperladmin=root@localhost -Dcc=gcc -Dcf_by=Red Hat, Inc. -Dprefix=/usr -Dvendorprefix=/usr -Dsiteprefix=/usr/local -Dsitelib=/usr/local/share/perl5 -Dsitearch=/usr/local/lib64/perl5 -Dprivlib=/usr/share/perl5 -Darchlib=/usr/lib64/perl5 -Dvendorlib=/usr/share/perl5/vendor_perl -Dvendorarch=/usr/lib64/perl5/vendor_perl -Dinc_version_list=5.10.0 -Darchname=x86_64-linux-thread-multi -Dlibpth=/usr/local/lib64 /lib64 /usr/lib64 -Duseshrplib -Dusethreads -Duseithreads -Duselargefiles -Dd_dosuid -Dd_semctl_semun -Di_db -Ui_ndbm -Di_gdbm -Di_shadow -Di_syslog -Dman3ext=3pm -Duseperlio -Dinstallusrbinperl=n -Ubincompat5005 -Uversiononly -Dpager=/usr/bin/less -isr -Dd_gethostent_r_proto -Ud_endhostent_r_proto -Ud_sethostent_r_proto -Ud_endprotoent_r_proto -Ud_setprotoent_r_proto -Ud_endservent_r_proto -Ud_setservent_r_proto -Dscriptdir=/usr/bin -Dusesitecustomize'
    hint=recommended, useposix=true, d_sigaction=define
    useithreads=define, usemultiplicity=define
    useperlio=define, d_sfio=undef, uselargefiles=define, usesocks=undef
    use64bitint=define, use64bitall=define, uselongdouble=undef
    usemymalloc=n, bincompat5005=undef
  Compiler:
    cc='gcc', ccflags ='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64',
    optimize='-O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic',
    cppflags='-D_REENTRANT -D_GNU_SOURCE -fno-strict-aliasing -pipe -fstack-protector -I/usr/local/include'
    ccversion='', gccversion='4.4.6 20110731 (Red Hat 4.4.6-3)', gccosandvers=''
    intsize=4, longsize=8, ptrsize=8, doublesize=8, byteorder=12345678
    d_longlong=define, longlongsize=8, d_longdbl=define, longdblsize=16
    ivtype='long', ivsize=8, nvtype='double', nvsize=8, Off_t='off_t', lseeksize=8
    alignbytes=8, prototype=define
  Linker and Libraries:
    ld='gcc', ldflags =' -fstack-protector'
    libpth=/usr/local/lib64 /lib64 /usr/lib64
    libs=-lresolv -lnsl -lgdbm -ldb -ldl -lm -lcrypt -lutil -lpthread -lc
    perllibs=-lresolv -lnsl -ldl -lm -lcrypt -lutil -lpthread -lc
    libc=, so=so, useshrplib=true, libperl=libperl.so
    gnulibc_version='2.12'
  Dynamic Linking:
    dlsrc=dl_dlopen.xs, dlext=so, d_dlsymun=undef, ccdlflags='-Wl,-E -Wl,-rpath,/usr/lib64/perl5/CORE'
    cccdlflags='-fPIC', lddlflags='-shared -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector --param=ssp-buffer-size=4 -m64 -mtune=generic'


Characteristics of this binary (from libperl):
  Compile-time options: MULTIPLICITY PERL_DONT_CREATE_GVSV
                        PERL_IMPLICIT_CONTEXT PERL_MALLOC_WRAP USE_64_BIT_ALL
                        USE_64_BIT_INT USE_ITHREADS USE_LARGE_FILES
                        USE_PERLIO USE_REENTRANT_API USE_SITECUSTOMIZE
  Built under linux
  Compiled at May  2 2012 10:29:48
  @INC:
    /usr/local/lib64/perl5
    /usr/local/share/perl5
    /usr/lib64/perl5/vendor_perl
    /usr/share/perl5/vendor_perl
    /usr/lib64/perl5
    /usr/share/perl5
    .
Flags: needinfo?(antovinraj)
(Reporter)

Comment 5

2 years ago
Any update

Comment 6

2 years ago
Make sure your DB accepts large packets, bigger than your file size limit, see e.g.  http://bugzilla.readthedocs.org/en/latest/installing/mysql.html#allow-large-attachments-and-many-comments

This could also be a bug with your Perl installation. 5.10.1 is not the best Perl version, which is unfortunately the one available in RHEL5.

You could also make sure that SELinux doesn't interfere with Bugzilla.

Anyway, this is a support question. Please visit https://www.bugzilla.org/support for help.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.