[Video]After user advances the video to the end, then taps the play button, the video will play from the start or be paused at there randomly.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Video
RESOLVED WONTFIX
2 years ago
2 months ago

People

(Reporter: Lance(leave from Mozilla), Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-v2.5 affected, b2g-master affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8701415 [details]
logcat_0851.txt

[1.Description]:
[Flame KK master&v2.5][Aries KK master][Video]Select a video to play, tap the fast-forword button to advance video to the end.Then tap the play button, the video will play from the start or be paused at there randomly.
See attachment: "logcat_0851.txt"&"Flame KK master.3GP"
Found time: 08:51

[2.Testing Steps]: 
Precondition: 
There're some videos in the DUT.

1.Launch the Video app.
2.Select a video to play.
3.Tap the fast-forward button to advance to the end.
4.Tap the play button and observe.

[3.Expected Result]: 
Step4.The video will play again from the start.

[4.Actual Result]: 
Step4. The video will play from the start or be paused at there randomly.

[5.Reproduction build]: 
Device: Flame KK master 512mb (affected)
Build ID               20151222030233
Gaia Revision          f3cf488a97ecaec43369f3e3d8a7dda52be019f9
Gaia Date              2015-12-22 02:20:26
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ad16863d1d45bd3fd7906c76fa1ac1e12d24a133
Gecko Version          46.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151222.071644
Firmware Date          Tue Dec 22 07:16:57 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK v2.5 512mb (affected)
Build ID               20151218180935
Gaia Revision          eeed1451e0e48b63abe3199e4d6906adc2a762d2
Gaia Date              2015-12-17 14:53:36
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/766600655dfb1b67c380b9da4f4b19acb505a858
Gecko Version          44.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151218.172320
Firmware Date          Fri Dec 18 17:23:30 UTC 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Flame KK v2.2 512mb (unaffeced)
Build ID               20151222032500
Gaia Revision          885647d92208fb67574ced44004ab2f29d23cb45
Gaia Date              2015-10-07 13:05:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2120b3e6f680
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151222.065319
Firmware Date          Tue Dec 22 06:53:30 EST 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Device: Aries KK master (affected)
Build ID               20151222115209
Gaia Revision          f3cf488a97ecaec43369f3e3d8a7dda52be019f9
Gaia Date              2015-12-22 02:20:26
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/ad16863d1d45bd3fd7906c76fa1ac1e12d24a133
Gecko Version          46.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151222.111221
Firmware Date          Tue Dec 22 11:12:28 UTC 2015
Bootloader             s1

Device: Aries KK v2.5 (unaffected)
Build ID               20151222010746
Gaia Revision          42aa9b91a231572138509bbd942d918d0293110a
Gaia Date              2015-12-21 22:48:19
Gecko Revision         http://hg.mozilla.org/releases/mozilla-b2g44_v2_5/rev/9c525eef094b710e8ea6d00613200282acf9b682
Gecko Version          44.0
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151222.001825
Firmware Date          Tue Dec 22 00:18:33 UTC 2015
Bootloader             s1

[6.Reproduction Frequency]: 
occasionally Recurrence,5/10

[7.TCID]: 
Free Test

Comment 1

2 years ago
Created attachment 8701419 [details]
Bug video: Flame KK master.3GP

Updated

2 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-v2.5: --- → affected
status-b2g-master: --- → affected
Keywords: regression
(Reporter)

Updated

2 years ago
QA Contact: liuke
(Reporter)

Comment 2

2 years ago
mozilla-inbound Regression Window:

Last Working Environmental Variables:
Device:Flame KK master (512mb)
Build ID               20151204120352
Gaia Revision          e9419046f360dd05b2717c4994990608519b93e4
Gaia Date              2015-12-03 21:33:30
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/1f0e79c35b56d895e1b2bc9bbeca2eddfe387583
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151206.064055
Firmware Date          Sun Dec  6 06:41:08 EST 2015
Fireware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Environmental Variables:
Device: Flame KK master (512mb)
Build ID               20151204131728
Gaia Revision          e9419046f360dd05b2717c4994990608519b93e4
Gaia Date              2015-12-03 21:33:30
Gecko Revision         https://hg.mozilla.org/integration/mozilla-inbound/rev/7f38782313bef9d359f7fb37ef331132e521c97c
Gecko Version          45.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20151206.064055
Firmware Date          Sun Dec  6 06:41:08 EST 2015
Fireware Version       v18D v4
Bootloader             L1TC000118D0

First Broken Gaia & Last Working Gecko - issue DOES NOT repro
Gaia Revision
e9419046f360dd05b2717c4994990608519b93e4
Gecko Revision 
https://hg.mozilla.org/integration/mozilla-inbound/rev/1f0e79c35b56d895e1b2bc9bbeca2eddfe387583

First Broken Gecko & Last Working Gaia – issue DOES repro
Gaia Revision
e9419046f360dd05b2717c4994990608519b93e4
Gecko Revision  
https://hg.mozilla.org/integration/mozilla-inbound/rev/7f38782313bef9d359f7fb37ef331132e521c97c

Gecko pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=1f0e79c35b56d895e1b2bc9bbeca2eddfe387583&tochange=7f38782313bef9d359f7fb37ef331132e521c97c

Hi,Andrea
   This bug seems to be caused by Bug 1230509 , could you help to check the pushlog?

Thank you.
QA Whiteboard: [MGSEI-Triage+]
Flags: needinfo?(amarchesini)
QA Contact: liuke
Is it possible to reproduce this issue using desktop? or b2g desktop?
Flags: needinfo?(amarchesini) → needinfo?(liuke)
(Reporter)

Comment 4

2 years ago
Hi Andrea,
This bug can’t be reproduced on MAC OS system and Windows system when use default player by the STR in comment 0.
Actual results: Fast forward to the end, tap the play button, the video will play again from the start.
Hope this information helps.
Flags: needinfo?(liuke) → needinfo?(amarchesini)
Flags: needinfo?(amarchesini)

Comment 5

2 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 2 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.