Closed Bug 12348 Opened 20 years ago Closed 19 years ago

DOM1 Errata: defaultChecked doesn't reset checkbox

Categories

(Core :: DOM: Core & HTML, defect, P3)

defect

Tracking

()

VERIFIED DUPLICATE of bug 62043

People

(Reporter: dbaron, Assigned: pollmann)

References

()

Details

DESCRIPTION:  According to the DOM1 Errata,
http://www.w3.org/DOM/updates/REC-DOM-Level-1-19981001-errata.html ,
HTMLInputElement::defaultChecked should reset the value of checked as well.  It
doesn't.  (This works for the other things in the errata, except selects.)

STEPS TO REPRODUCE:
1) Load above URL
2) note initial state of checkboxes: first is checked, second isn't
3) press "test Errata" button

ACTUAL RESULTS:
 * 15th line of output is red
 * the checkboxes stay in their initial state

EXPECTED RESULTS:
 * 15th line of output is green
 * the checkboxes switch so the second is checked and the first isn't

DOES NOT WORK CORRECTLY ON:
 * Linux, apprunner, 1999-08-20-13-M10
Assignee: vidur → pollmann
This one's for you, Eric.
OS: Linux → All
Hardware: PC → All
ALSO DOES NOT WORK CORRECTLY ON:
 * Windows, apprunner, 1999-08-24-09-M10

Marking All/All
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
Target Milestone: M11
Just checked in a fix.  To verify, follow directions in the original bug report.
Status: RESOLVED → VERIFIED
Verified fixed, Linux apprunner 1999-10-15-11-M11.
Fixing 53860 reopens this bug, but fixes many existing webpages.  Marking this
bug as a dup of this since they are tracking the same issue.
Status: VERIFIED → REOPENED
Resolution: FIXED → ---

*** This bug has been marked as a duplicate of 53860 ***
Status: REOPENED → RESOLVED
Closed: 20 years ago19 years ago
Resolution: --- → DUPLICATE
Oops, wrong bug!
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
This is really a dup of bug 62043, where Johnny mentions that he is actually
going to push to get the spec fixed, not just break with standards compliance
here.  :)

*** This bug has been marked as a duplicate of 62043 ***
Status: REOPENED → RESOLVED
Closed: 19 years ago19 years ago
Resolution: --- → DUPLICATE
VERIFIED dup
Status: RESOLVED → VERIFIED
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.