OSX - Audible glitch occurs in <audio> tag (or built-in) player after repositioning play-head and hitting play

RESOLVED FIXED

Status

()

Core
Audio/Video: Playback
--
critical
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Bob Merkel, Unassigned)

Tracking

43 Branch
Unspecified
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/47.0.2526.106 Safari/537.36

Steps to reproduce:

Using OSX Ver. 10.11.1 (15B42), FF Ver. 43.0

1) Using FF on a MAC, navigate to the following .MP3 file:
http://mediazam.com/test/440.mp3

(NOTE: The .MP3 file auto-plays a pure, 440Hz tone.)

2) Click Pause.

3) Reposition the playhead to somewhere else on the playbar

4) Hit play.

*) Repeat until you hear the problem


Actual results:

When you hit play (step 4), an audible glitch (approx. 30ms) occurs just before playback.
The "glitch" is some other audio than the 440Hz tone.

This also occurs when repositioing the playhead during playback


Expected results:

A pure tone should be heard when hitting Play.
Comparison: The glitch is not heard when using any other browser on a PC, or OSX, Chrome, or in IOS.
(Reporter)

Updated

2 years ago
Severity: normal → critical
OS: Unspecified → Mac OS X
@Reporter - are you still experiencing this issue?

I cannot reproduce - MAC 10.11 or Windows 10.
Version 	43.0.3
Build ID 	20151223140742
User Agent 	Mozilla/5.0 (Macintosh; Intel Mac OS X 10.11; rv:43.0) Gecko/20100101 Firefox/43.0
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(bob.merkel)
Resolution: --- → WORKSFORME
(Reporter)

Comment 2

2 years ago
MAC      10.11.2
Version  43.0.3

The issue is still happening for me and has also been confirmed by another user.

I have created a live screen-capture for both FF (has issue) and Chrome (no issue).
Plus I have included screen-shots showing the audio waveform created for both browsers during playback.
The FF waveform shows where the pure tone is being disrupted when played.

Please download here: http://mediazam.com/test/Caps_Wavefroms.zip
Status: RESOLVED → UNCONFIRMED
Resolution: WORKSFORME → ---
@Reporter, thank you for attachment demonstrating the issue.
Status: UNCONFIRMED → NEW
Component: Untriaged → Audio/Video: Playback
Ever confirmed: true
Product: Firefox → Core
This is likely fix in 44 and later. Please retest with Firefox Developer Edition. 

The apple MP3 player was replaced with our own in 44
(Reporter)

Comment 5

2 years ago
(In reply to Jean-Yves Avenard [:jya] from comment #4)
> This is likely fix in 44 and later. Please retest with Firefox Developer
> Edition. 
> 
> The apple MP3 player was replaced with our own in 44

Confirmed Jean-Yves - the issues is fixed in 45.0a2 (2015-12-30)

Where can I learn about when these changes will appear in FF regular Edition?

Thanks!
Flags: needinfo?(bob.merkel)
A cycle is 6 weeks between releases.. Current official release is 43 and dev edition is 45.
https://wiki.mozilla.org/RapidRelease/Calendar so March 8th
Status: NEW → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.