I keep asserting in RDFXMLDataSourceImpl::Init

VERIFIED FIXED in M11

Status

SeaMonkey
General
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Scott MacGregor, Assigned: Chris Waterson)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
This may have been reported already, but I've been seeing this assertion for
a while now and wanted to make sure it was reported somewhere.

When bringing up the browser, I always assert in RDFXMLDataSourceImpl::Init with
the following assertion:

    rv = gRDFService->RegisterDataSource(this, PR_FALSE);
    NS_ASSERTION(NS_SUCCEEDED(rv), "somebody already registered this");

In order to see this problem, you need to run apprunner with the -mail extension
first. Then bring up navigator from messenger. It looks like by bringing up
messenger, the RDFXMLDatasource is getting registered. Yet for some reason we
try to register it again in response to opening up a navigator window.

I can post a stack trace if you have a problem reproducing this.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M10
(Assignee)

Comment 1

18 years ago
I'll take a look...
(Assignee)

Comment 2

18 years ago
mscott: i am not seeing this. can you post a stack trace?
(Assignee)

Comment 3

18 years ago
...but I do see that the window only ever comes up with about:blank (i.e., it
doesn't seem to redirect the default home page.)
(Reporter)

Comment 4

18 years ago
Sure Chris. Here goes:

nsDebug::Assertion(const char * 0x017bf8e0, const char * 0x017bf8cc, const char
* 0x017bf89c, int 680) line 176 + 13 bytes
RDFXMLDataSourceImpl::Init(RDFXMLDataSourceImpl * const 0x04702994, const char *
0x04703760) line 680 + 39 bytes
XPTC_InvokeByIndex(nsISupports * 0x04702994, unsigned int 3, unsigned int 1,
nsXPTCVariant * 0x0012e2dc) line 135
nsXPCWrappedNativeClass::CallWrappedMethod(JSContext * 0x04457c60,
nsXPCWrappedNative * 0x04703910, const XPCNativeMemberDescriptor * 0x04703984,
nsXPCWrappedNativeClass::CallMode CALL_METHOD, unsigned int 1, long *
0x03c91a5c, long * 0x0012e4f8) line 511 + 44 bytes
WrappedNative_CallMethod(JSContext * 0x04457c60, JSObject * 0x03cf37f0, unsigned
int 1, long * 0x03c91a5c, long * 0x0012e4f8) line 170 + 34 bytes
js_Invoke(JSContext * 0x04457c60, unsigned int 1, unsigned int 0) line 654 + 26
bytes
js_Interpret(JSContext * 0x04457c60, long * 0x0012ed24) line 2228 + 15 bytes
js_Invoke(JSContext * 0x04457c60, unsigned int 0, unsigned int 0) line 670 + 13
bytes
js_Interpret(JSContext * 0x04457c60, long * 0x0012f50c) line 2228 + 15 bytes
js_Invoke(JSContext * 0x04457c60, unsigned int 0, unsigned int 0) line 670 + 13
bytes
js_Interpret(JSContext * 0x04457c60, long * 0x0012fd98) line 2228 + 15 bytes
js_Execute(JSContext * 0x04457c60, JSObject * 0x03c23718, JSScript * 0x04700db0,
JSFunction * 0x00000000, JSStackFrame * 0x00000000, int 0, long * 0x0012fd98)
line 827 + 13 bytes
JS_EvaluateUCScriptForPrincipals(JSContext * 0x04457c60, JSObject * 0x03c23718,
JSPrincipals * 0x046852a0, const unsigned short * 0x04454a60, unsigned int 6,
const char * 0x00000000, unsigned int 0, long * 0x0012fd98) line 2596 + 27 bytes
GlobalWindowImpl::RunTimeout(nsTimeoutImpl * 0x04688c10) line 1701 + 79 bytes
nsGlobalWindow_RunTimeout(nsITimer * 0x04688b80, void * 0x04688c10) line 1603 +
15 bytes
TimerImpl::Fire(unsigned long 631045046) line 308 + 17 bytes
TimerImpl::ProcessTimeouts(unsigned long 631045046) line 187
FireTimeout(HWND__ * 0x00000000, unsigned int 275, unsigned int 5606, unsigned
long 631045046) line 101 + 9 bytes
USER32! 77e712a4()
nsAppShellService::Run(nsAppShellService * const 0x00effc80) line 446
m
(Assignee)

Comment 5

18 years ago
Is yer sidebar open? (Mine wasn't...)
(Reporter)

Comment 6

18 years ago
ahhh...yes my sidebar is open in messenger when I try to bring up navigator.
(and I'm also seeing the about:blank problem which looks like another bug...i'll
investigate).
(Assignee)

Updated

18 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Assignee)

Comment 7

18 years ago
This was a dumbass mistake. That assert shouldn't be there. I've removed it.

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 8

18 years ago
Marking Verified per last comments.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.