Regression in WebGL 1.0.2 conformance: conformance/more/functions/texImage2DBadArgs.html

RESOLVED FIXED

Status

()

Core
Canvas: WebGL
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: Luke, Unassigned)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: webgl-conformance gfx-noted)

(Reporter)

Description

2 years ago
Steps to reproduce:
Navigate to:
https://www.khronos.org/registry/webgl/conformance-suites/1.0.2/conformance/more/functions/texImage2DBadArgs.html

Results:
FAIL
testTexImage2D
FAIL: bad internal format/format (in assertGLError: expected: INVALID_ENUM actual: INVALID_VALUE)

(function (){ gl.texImage2D(gl.TEXTURE_2D, 0, gl.RGBA, 0,0,0,gl.RGBA,gl.UNSIGNED_BYTE, null); })
FAIL: bad format (in assertGLError: expected: INVALID_ENUM actual: INVALID_OPERATION)

(function (){ gl.texImage2D(gl.TEXTURE_2D, 0, gl.RGBA, 1,1,0,gl.FLOAT,gl.UNSIGNED_BYTE, null); })


Chrome passes all the tests. Firefox 43.0.1 passes, but now fails with nightly in both Windows and Linux.
(Reporter)

Updated

2 years ago
Whiteboard: webgl-conformance gfx-noted
(Reporter)

Updated

2 years ago
Blocks: 845345
(Reporter)

Comment 1

2 years ago
Looks like this was fixed upstream. 

https://www.khronos.org/registry/webgl/sdk/tests/conformance/more/functions/texImage2DBadArgs.html?webglVersion=1&quiet=0

PASS
testTexImage2D
PASS: zero size (in assertOk)

(function (){ gl.texImage2D(gl.TEXTURE_2D, 0, gl.RGBA, 0,0,0,gl.RGBA,gl.UNSIGNED_BYTE, null); })

possibility by:

https://github.com/KhronosGroup/WebGL/commit/2e758d2fd138855bdc787f842f3615aeeec328b5
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.