ctrl-click on an item don't selects it and displays wrong popup

RESOLVED WORKSFORME

Status

SeaMonkey
MailNews: Message Display
RESOLVED WORKSFORME
16 years ago
12 years ago

People

(Reporter: joseph, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
with 0.9.8 / OSX 10.1.1 , clicking on an item that makes mozilla to compute
duing 1-2 sec. makes the popup menu to appear .

reproductible only when mozilla computes a bit

-open mail/news
-click and release on a folder or an account name. (note : it is better to
choose a news folder as mozilla will compute lengthily)

result : folder content and popup menu appears

expected result : folder content appears .

this is also reproductible when you click on a toolbar favorites's bookmark
folder with a lot of bookmarks inside .

ps: it's not only a mail/news issue but i didn't found a better category .

Updated

16 years ago
QA Contact: esther → olgam

Comment 1

16 years ago
1-2 sec. processing time is actually the time when we expect the popup menu to
appear. It is the same as holding mouse click little bit for getting popup menu. 
I saw context menu appeared just with a click (without holding) on the previous
builds of trunk. From 02-04-2002 build is fine now.
You are on branch build. What build date?
(Reporter)

Comment 2

16 years ago
I just tested the latest nightly and the bug disapeared ... (i had 0.9.8 release
for OS X : 2002020411)
also , i noticed that right-clicking (ctrl-click) on an folder displays a popup
menu for the previously selected one . I didn't found any bug in bugzilla for
this issue , should i enter a new one ?

Comment 3

16 years ago
About displaying a popup menu for the previously selected folder - did you
select first the new folder? If previous folder is still selected, then we do
'Ctrl+click' on another one - it is logical to see context menu for previous one. 
I asked jglick and she clarified:  From OSX UI Guidelines: "Many interface
elements display a contextual menu when the user presses the Control key while
clicking or pressing the item. The contextual menu provides convenient access to
often-used commands associated with the item." "The Control key is used to
modify the functions of other keys, with terminal-emulation programs for
Control-key sequences, and, with a mouse click, to display contextual menus, so
with Mac OS, Ctrl+click selects the item And displays the context menu for it."
(Reporter)

Comment 4

16 years ago
I select a folder (or another kind of item) and then ctrl-click on another .
as you said ,  'Ctrl+click selects the item And displays the context menu for it.'
in that case , ctrl-click don't selects the item , and so , displays the context
menu for the previous one .

Comment 5

16 years ago
You might want to change the summary in this case.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 6

16 years ago
hum , yes , i thought it was necessary to open a new bug ...
the problem is also present in bookmark tab / manager .
Summary: popup menu unexpectedly appears when mozilla computes lengthily → ctrl-click on a folder don't selects it and displays wrong popup
(Reporter)

Comment 7

16 years ago
Update with 0.9.9 :
the bug is no longer reproductible with mail folders :
now , when you select a folder and ctrl-click on another , the popup appears and
then , the second folder is selected (i think folder should be selected before
popup menu appears ...). items in the popup menu applies to the second folder as
espected.
the bug is still present in bookmark manager and tab , and on messages (mail
folder content) 
Summary: ctrl-click on a folder don't selects it and displays wrong popup → ctrl-click on an item don't selects it and displays wrong popup
(Reporter)

Comment 8

16 years ago
I just tested with 2002032208 nightly (with MacOS 10.1.3) and the bug is no
longer present in thread pane . it is already present in bookmark tab and
manager , in history tab and window , and in adress book tab .
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail
(Reporter)

Updated

12 years ago
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.