Plus key of keyboard does not zoom in an image on google drive

RESOLVED INVALID

Status

()

RESOLVED INVALID
3 years ago
2 years ago

People

(Reporter: Towkir, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

3 years ago
Steps to reproduce:
1. Visit https://drive.google.com/file/d/0B0v8z5-ZdqsSM2t1em5Nal9nOFE/view?usp=sharing
2. press the "+" button (which is at the numeric part of your {desktop}* keyboard)

Result: 
The image is zoomed in, but the quick finder (ctrl+F) comes up and starts searching for the character "+"

Expected Result:
The image should be zoomed in and the "-" button should zoom it out.
"Find on page" should not be activated
As the quick find box comes up, no longer zoom in/out is done unless the searchbox is closed manually.

Visit the url (image) from a chrome browser to experience the expected result yourself 

Thanks

Comment 1

3 years ago
WFM on Fx43 Win10, quick finder does not comes up.


Hmmm, it happen when "Search for text when I start typing" option enabled.
Component: Untriaged → Keyboard Navigation
Summary: Plus button does not zoom in an image on google drive → Plus key of keyboard does not zoom in an image on google drive

Comment 2

3 years ago
This doesn't look like firefox bug, because focused chrome inputs should not pass pressed keys to web
 pages. I don't want extra actions when I'm searching for a string containing web page's hotkeys.
I think Google Drive devs should use e.preventDefault() for hotkeys, because it seems the only option
 here. I mean, they could do that, but they can as well blame "that strange type-to-find feature".
Status: UNCONFIRMED → NEW
Component: Keyboard Navigation → Desktop
Ever confirmed: true
Product: Firefox → Tech Evangelism

Comment 3

2 years ago
yes I'm willing to close this as worksforme. 
It's not sure that both Firefox and Google have anything to do here. 

Plus I don't think we will be successful in asking Google to do a special hack for a specific feature of Firefox.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

2 years ago
I thought it should either zoom or trigger the find on page feature.
But it(pressing + button) zooms for the first step and triggers find on page too, 
then zooming is disabled unless you close the searchbox (find on page) and after closing that, you can zoom again, 

Same goes for zooming out, activities are random. Confusing !!!

Comment 5

2 years ago
Mike, can the FAYT code just prevent the web from seeing these keypresses or is that not feasible? If not, I suggest invalid/wontfix.
Status: RESOLVED → REOPENED
Component: Desktop → Find Toolbar
Flags: needinfo?(mdeboer)
Product: Tech Evangelism → Toolkit
Resolution: WORKSFORME → ---
Ahmed, do you have `accessibility.typeaheadfind` set to TRUE in 'about:config'? If so, there's not much we can do about it, I'm afraid.
Flags: needinfo?(mdeboer) → needinfo?(3ugzilla)
(Reporter)

Comment 7

2 years ago
Yes, I have it set to true, sadly.
Flags: needinfo?(3ugzilla)

Updated

2 years ago
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.