Firefox Nightly (46.0a1) 'locks up' using LastPass in some situations, unsure if FF or Lastpass

RESOLVED DUPLICATE of bug 1237884

Status

()

Firefox
Extension Compatibility
--
critical
RESOLVED DUPLICATE of bug 1237884
2 years ago
2 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

({hang})

46 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

687.24 KB, application/rar
Details
325.22 KB, text/plain
Details
(Reporter)

Description

2 years ago
Created attachment 8702463 [details]
FFCrash.rar

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20151228030213

Steps to reproduce:

*Fresh* (new profile) copy of Firefox Nightly on 3 different machines, including a blank "clean" VM
Install Lastpass plugin, which is apparently listed as compatible with Firefox nightly.
(ver 3.2.41)

Attempted to open the HTML / Web login page for my QBittorrent server, upon using the right click, context menu and auto filling in the user / pass, Firefox stops responding to input, as if the rendering engine is dead?
(The program is NOT listed as "not responding" under the Task Manager)

Machines are Windows 7, Windows 7, Windows 10 (VM)





NOTE: I do not know how to program, nor do I understand backend 'engines' to websites. I don't know what tech QBittorrent uses to produce web pages / logins, if it's Java or umm CSS or whatever the term is, *HOWEVER* I suspect the issue I'm having will likely be applicable to any sites which use the same underlying login method, hence reporting.

I've included the 'page source' for my Qbittorrent server in text form, I don't know if this can help.
I've included a video of the fault in Windows media format (any machine past Windows XP should be able to play it)

This is a reproducible issue, consistently for me.






Actual results:

Program graphically locked up, but according to Windows task manager, is not in a crashed state.
Need to end task for the Firefox process and re-start it to solve this.
Has occurred for 2 versions of FF Nightly now.


Expected results:

Username and password should've been passed into the 2 boxes allowing me to login.
(Reporter)

Comment 1

2 years ago
NOTE: It's entirely possible this is a LASTPASS issue and not a Firefox issue, I've let them know as well,  I apologise if this wastes someones time, however I'm unable to tell which is which.
OS: Unspecified → Windows 7
Hardware: Unspecified → x86_64
(Reporter)

Comment 2

2 years ago
Comment on attachment 8702463 [details]
FFCrash.rar

Sorry I was going to attach 2 files seperately but it only let me put in one file, I hope RAR is ok.

Comment 3

2 years ago
User-Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0
Build-ID: 20151228030213

Hey ScottyLans,
I can confirm this behavior with Windows 7 x64 and the latest Firefox Nighly.
With WinDBG, I tried to get further information on this bug and in the second, when the browser stopped responding, thousands of "[JavaScript Warning: "unsafe CPOW usage" {file: "file:///C:/Users/[REDACTED]/AppData/Roaming/Mozilla/Firefox/Profiles/lj6rg42v.dev-edition-default/extensions/support@lastpass.com/components/lastpass.js" line: 143}]" ran over my screen (in the debugging tool).
I guess that this is not a Firefox Bug, but a LastPass one.
I think that there is an infinite loop in the lastpass.js file.

I will report this Bug to LastPass Support, if that's okay for you.

Felix

Comment 4

2 years ago
Just as Addition for all People who don't have a QBittorrent Server:
URL: http://qb.abeido.se/

Felix

Comment 5

2 years ago
Created attachment 8702628 [details]
LastpassBug.TXT

This is the Windbg output while opening http://qb.abeido.se/ and triggering the bug.

Updated

2 years ago
Severity: normal → critical
Component: Untriaged → Extension Compatibility
Keywords: hang
(Reporter)

Comment 6

2 years ago
Thanks for the followup, I wasn't sure if this wasn't going to go anywhere.
I have infact reported it to the lastpass people also
https://forums.lastpass.com/viewtopic.php?f=14&t=193615
(Reporter)

Comment 7

2 years ago
UPDATE: more information, as per my post @ Mozilla forums.

Using Firefox Nightly 46.0a1 (2015-12-29) 
LastPass dev edition 3.2.46a  (for testing, as recommended)
*BRAND NEW PROFILE*

Upon installing Lastpass and logging in, (no longer requires a re-start???) the QBittorrent issue is fixed. (Good)
HOWEVER, as soon as you re-start Firefox, e10s (multi-core stuff) is instantly disabled with the standard bug error. (Bad)
https://bugzilla.mozilla.org/show_bug.cgi?id=1198459

Virtually a fresh copy of Windows.
Definitely a brand new FFox instance.
Latest dev build of Lastpass.

Clearly the multi-core code in FF does not like Lastpass.

Comment 8

2 years ago
I'm unable to reproduce this, but it sounds like a CPOW bug within Firefox itself that LastPass is tickling, similar to this one:

https://bugzilla.mozilla.org/show_bug.cgi?id=1188912

You're correct that if you have e10s enabled, you should be using the LastPass beta channel:

https://addons.mozilla.org/en-us/firefox/addon/lastpass-password-manager/versions/beta

I'm also unable to reproduce your problem where e10s is disabled after installing the LastPass beta channel and restarting Nightly.  I assume the only place we could be calling into accessibility routines is within our binary component.  Our binary component does include some calls to accessibility routines for the purpose of interacting with HTTP basic authentication windows in other browsers, but we shouldn't be calling them in the Firefox case, since we handle HTTP basic authentication by modifying the window via XUL.  Is there a way to find out exactly what is being called that's triggering Firefox to disable e10s?
Is this still an issue for you?
Flags: needinfo?(bugzilla)
(Reporter)

Comment 10

2 years ago
Sorry for the late response, if someone in the dev team can close this and put the solution notes as required installation of dev / beta version of lastpass.
(Version 3.x?? current release version at time of bug reporting *WAS* incompatible with that build of FF Nightly, since I've switched to the dev channel for Lasptpass, that particular bug is no good)
Flags: needinfo?(bugzilla)
(Reporter)

Comment 11

2 years ago
Oh on more OFF TOPIC THING
For the love #$%@#%^ where the heck is the "forgot password to bugzilla" button? That's why this is a 4 day late reply, I had to try all kinds of random passwords in my memory to log in.  (and no, lastpass didn't have the pass saved, ironically, it does now)
Depends on: 1237884
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
No longer depends on: 1237884
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 1237884
You need to log in before you can comment on or make changes to this bug.