If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

webextension cross-domain xhr

RESOLVED DUPLICATE of bug 1205886

Status

()

Toolkit
WebExtensions: Untriaged
RESOLVED DUPLICATE of bug 1205886
2 years ago
2 years ago

People

(Reporter: adrenalin3, Unassigned)

Tracking

44 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

591 bytes, application/x-xpinstall
Details
(Reporter)

Description

2 years ago
Created attachment 8702546 [details]
xhr.xpi

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:44.0) Gecko/20100101 Firefox/44.0
Build ID: 20151221151411

Steps to reproduce:

Go to some webpage.
The webextension try to load https://www.mozilla.org/en-US/ via XHR


Actual results:

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://www.mozilla.org/en-US/.


Expected results:

The documentation said content scripts can make cross-domain XHR requests
https://developer.mozilla.org/en-US/Add-ons/WebExtensions/Anatomy_of_a_WebExtension

Webextension permission added for https://*/*
(Reporter)

Updated

2 years ago
Component: Untriaged → WebExtensions
Product: Firefox → Toolkit
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1205886
You need to log in before you can comment on or make changes to this bug.