Closed Bug 1235591 Opened 4 years ago Closed 4 years ago

Add Android builds to Bouncer

Categories

(Release Engineering :: Release Automation: Other, defect)

defect
Not set

Tracking

(firefox46 fixed, b2g-v2.5 fixed)

RESOLVED FIXED
Tracking Status
firefox46 --- fixed
b2g-v2.5 --- fixed

People

(Reporter: rail, Assigned: rail)

References

Details

Attachments

(1 file)

1) Add MH configs
2) Add android-* platforms to bouncer
3) Add latest aliases to bouncer
4) Add buildbot builders
5) Modify configs to to make postrelease to update bounce raliases
(In reply to Rail Aliiev [:rail] from comment #0)
> 1) Add MH configs

It turns out this was the only thing that I needed to do. Kim has addresses the rest of the list already.

The main change here is "add-locales": False to make "multi" work (it's not a locale for reals).

I played with 44.0b1  and it worked fine:

$ curl -sI http://download.mozilla.org/\?product\=Fennec-44.0b1\&os\=android-api-11\&lang\=multi | grep ^Location:
Location: http://download.cdn.mozilla.net/pub/mobile/releases/44.0b1/android-api-11/multi/fennec-44.0b1.multi.android-arm.apk


> 2) Add android-* platforms to bouncer

android and android-x86 were there, added android-api-9
Attachment #8702634 - Flags: review?(jlund)
Comment on attachment 8702634 [details] [diff] [review]
fennec_bouncer.diff

Review of attachment 8702634 [details] [diff] [review]:
-----------------------------------------------------------------

::: testing/mozharness/configs/releases/bouncer_fennec.py
@@ +3,2 @@
>      "products": {
> +        "apk": {

this is just used for logging right?

@@ +8,2 @@
>              "paths": {
> +                "android-api-11": {

same with this. afaict this is just for logging

@@ +21,3 @@
>              },
>          },
>      },   

nit: whitespace
Attachment #8702634 - Flags: review?(jlund) → review+
Blocks: 1235623
Blocks: 1235625
https://hg.mozilla.org/mozilla-central/rev/13883b9ed49d
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Duplicate of this bug: 1226474
You need to log in before you can comment on or make changes to this bug.