wiki.mozilla.org serves json for a wiki page name ending in .json

RESOLVED DUPLICATE of bug 1235725

Status

()

Firefox
Developer Tools: JSON Viewer
RESOLVED DUPLICATE of bug 1235725
2 years ago
2 years ago

People

(Reporter: Callek, Assigned: jakem)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
Visit:
https://wiki.mozilla.org/ReleaseEngineering/How_To/allthethings.json

Then visit:
https://wiki.mozilla.org/ReleaseEngineering/How_To/allthethings.%6a%73%6f%6e

Notice the latter is a real page, (and should be a real page) while the former is served as json by the web server and firefox tries to parse as json.

Yes the page could be renamed but I don't think we want real wiki pages able to be served as json anyway...

Updated

2 years ago
Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/2368]
(Assignee)

Comment 1

2 years ago
??? both look normal to me. Content-Type: text/html, looks like a normal wiki page. Checked in Chrome and Firefox Beta.

Some addon breaking it for you, maybe? Can anyone else replicate?
Flags: needinfo?(bugspam.Callek)

Updated

2 years ago
Assignee: server-ops-webops → nmaul
(Reporter)

Comment 2

2 years ago
I'm on dev edition, so maybe thats the cause?  https://developer.mozilla.org/docs/Tools/Valence is listed as an addon in my addons list, and I've not actively chosen to download... let me look again...

And it seems that it does indeed serve as ```Content-Type:"text/html; charset=UTF-8"``` so probably an addon/dev-edition issue.
(Reporter)

Updated

2 years ago
Component: WebOps: IT-Managed Tools → Developer Tools: JSON Viewer
Flags: needinfo?(bugspam.Callek)
Product: Infrastructure & Operations → Firefox
QA Contact: smani
Version: other → unspecified
(Reporter)

Comment 3

2 years ago
And to be clear, even with Valence disabled, it still has this behavior
Whiteboard: [kanban:https://webops.kanbanize.com/ctrl_board/2/2368]

Comment 4

2 years ago
I'm also having this issue with Developer Edition (FF45).
I came across this while checking https://docs.npmjs.com/files/package.json , which should render as a HTML document, and also contains this header in the response. 
> Content-Type:"text/html; charset=UTF-8"

Thanks for the workaround in the description!
duplicate of this bug 1235725 perhaps?
(Reporter)

Comment 6

2 years ago
(In reply to Robert Longson from comment #5)
> duplicate of this bug 1235725 perhaps?

They are indeed one and the same issue afaict. Not sure which way to dupe though.
I'm arbitrarily duping this forward to bug 1235725, since that bug has a "regression" bug comment and this bug is much noisier for its time spent going around the triage queues.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1235725
You need to log in before you can comment on or make changes to this bug.