If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

PCToLineNumber incorrectly resets column number

RESOLVED FIXED in Firefox 46

Status

()

Core
JavaScript Engine
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: tromey, Assigned: tromey)

Tracking

unspecified
mozilla46
Points:
---

Firefox Tracking Flags

(firefox46 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Assignee)

Description

2 years ago
I found this while working on bug 1013219 and I'm breaking it out
into a separate bug for clarity.

The bug is that PCToLineNumber conditionally updates the line number,
but unconditionally clears the column number.  This means that in some
cases the column number is incorrect.
(Assignee)

Updated

2 years ago
Blocks: 1013219
(Assignee)

Comment 1

2 years ago
Created attachment 8702683 [details] [diff] [review]
rewrite PCToLineNumber

The patch.

Nick r+'d the basic idea in the other bug but I will re-request review
since I've updated some tests.
(Assignee)

Comment 2

2 years ago
Created attachment 8703016 [details] [diff] [review]
rewrite PCToLineNumber

Found one more regression from this.
Attachment #8702683 - Attachment is obsolete: true
(Assignee)

Comment 3

2 years ago
Comment on attachment 8703016 [details] [diff] [review]
rewrite PCToLineNumber

Here's the PCToLineNumber patch separated out.
It cleans up a few mysterious column number choices in the tests.

You've already ok'd the original patch; not sure if you are able
to review the test fixes as well?
Attachment #8703016 - Flags: review?(nfitzgerald)
(Assignee)

Comment 4

2 years ago
https://treeherder.mozilla.org/#/jobs?repo=try&revision=e9f9d96f1fca
Attachment #8703016 - Flags: review?(nfitzgerald) → review+

Comment 5

2 years ago
https://hg.mozilla.org/integration/fx-team/rev/9d5029646b52

Comment 6

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/9d5029646b52
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox46: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla46
You need to log in before you can comment on or make changes to this bug.