Smart keyword suggestion not showing icon in Unified Complete

RESOLVED DUPLICATE of bug 1178045

Status

()

Firefox
Location Bar
P3
normal
RESOLVED DUPLICATE of bug 1178045
2 years ago
11 months ago

People

(Reporter: Daniel Beardsmore, Unassigned)

Tracking

(Blocks: 1 bug, {regression})

43 Branch
x86_64
Windows 10
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fxsearch])

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151221130713

Steps to reproduce:

Assume a Quick Search bookmark (AKA smart keyword bookmark) called “Google”, keyword “g”, that searches http://www.google.co.uk/search?q=%s&hl=en. This bookmark has (and for the purposes of this bug, must have) a favicon assigned to it.

In the address bar, type the smart keyword followed by a search term, e.g. “g firefox”.


Actual results:

Unified Complete suggests the following:

[blank paper icon] www.google.co.uk: firefox [magnifying glass icon]

The name of the bookmark is ignored, and the favicon for the bookmark is also ignored.


Expected results:

The Unified Complete suggestion that appears should use the favicon assigned to the bookmark when making the suggestion. Ideally it should also use the name of the bookmark too.

My memory is ropey, but I'm pretty sure this worked correctly before 43. This appears to be a regression. I don't have a computer with Firefox 42 to hand to test.
(Reporter)

Updated

2 years ago
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

Updated

2 years ago
Duplicate of this bug: 1235646

Updated

2 years ago
Status: UNCONFIRMED → NEW
Component: Untriaged → Location Bar
Depends on: 995091
Ever confirmed: true
(Reporter)

Comment 2

2 years ago
No, this is not a duplicate of bug 1235646; please note that I filed both bugs within minutes of each other! Please re-read the steps to reproduce. This bug relates to an existing favicon not being shown.

Comment 3

2 years ago
(In reply to Daniel Beardsmore from comment #2)
> No, this is not a duplicate of bug 1235646; please note that I filed both
> bugs within minutes of each other! Please re-read the steps to reproduce.
> This bug relates to an existing favicon not being shown.

I think it has nothing to do with existing an favicon, it's just always uses a default icon.
(Reporter)

Comment 4

2 years ago
If this is a regression, it needs fixing. If it's not a regression, then consider this a feature request. I am certain that it used to show the favicon at some stage, but I forget when this stopped working.

Updated

11 months ago
Blocks: 1262507
Priority: -- → P3
Whiteboard: [fxsearch]

Comment 5

11 months ago
Can reproduce the good behavior on Nightly 2015-03-27.
Basically I think that regression range is the same as in bug 1178075. And also, if this is considered valid, then bug 1178075 should be reopened and this bug should be marked as duplicate.
Quotes:

bug 1178075 comment 2 (Marco Bonardo [::mak] 2015-06-28 04:44:27 PDT )
> since keywords are no more bookmarks, it's expected they don't have a favicon nor a star.

bug 1178075 comment 4 (Marco Bonardo [::mak] 2015-06-29 00:09:39 PDT )
> keywords only have keyword, uri and eventually POST data.

bug 1178045 comment 8 (Marco Bonardo [::mak] 2016-04-06 08:52:25 PDT )
> We should either:
> ...
> 2. try to guess a favicon for keywords as domain/favicon.ico

So, only 2 options are possible:
1) Keywords will "guess" favicons, therefore this will be fixed, just like bug 1178075, and resolution
  "WONTFIX" was invalid in that bug, and just used to keep more regressions in Firefox for a while.
2) Kwywords will NOT guess favicons, therefore this bug, bug 1178075, bug 1235646 are all "WONTFIX",
   because it was decided to keep as many regressions in Firefox as possible, forever.
Keywords: regression, regressionwindow-wanted
See Also: → bug 1178045, bug 1235646

Updated

11 months ago
See Also: → bug 1178075

Comment 6

11 months ago
right, this is a dupe of bug 1178045, and we should figure out https://bugzilla.mozilla.org/show_bug.cgi?id=1178045#c8
Status: NEW → RESOLVED
Last Resolved: 11 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1178045

Updated

11 months ago
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.