Smart keyword bookmark created without favicon

NEW
Unassigned

Status

()

P5
minor
3 years ago
6 months ago

People

(Reporter: public, Unassigned)

Tracking

43 Branch
x86_64
Windows 10
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151221130713

Steps to reproduce:

1. Visit https://bugzilla.mozilla.org/
2. Verify that the favicon for the above page is showing in the browser tab
3. Right-click the search field, and select Add a Keyword for this Search
4. Note where the bookmark will be saved (the default appears to be Bookmarks Menu)
4. Enter a keyword, and click Save


Actual results:

Locate the bookmark that was created: observe that the favicon previously confirmed in step 2 has been ignored and a blank page icon has been used for the bookmark instead.

Check the properties for the bookmark and verify that the URL is for the same website: https://bugzilla.mozilla.org/ — that is, even though Firefox has likely never loaded the page in question, it does already know what favicon the site uses (give or take the extremely unlikely and probably irrelevant situation of a site using different favicons for different pages!)


Expected results:

I would expect Firefox to make use of the favicon of the current page, so long as the search URL points to the same website (protocol/domain/port).
(Reporter)

Updated

3 years ago
Severity: normal → minor
OS: Unspecified → Windows 10
Hardware: Unspecified → x86_64

Comment 1

3 years ago
Same issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1235645
(Reporter)

Comment 2

3 years ago
No, this is not a duplicate of bug 1235645! Please note that I filed both bugs within minutes of each other and they refer to different issues.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
I can reproduce this. I also agree it is not a duplicate of 1235645. Setting to Firefox: Bookmarks and History. For further clarity: explanations/investigations as my expectation is different. 
a) Google search field displays the favicon for Google
b) Bing search field displays the favicon for Bing
c) Bugzilla@Mozilla search field displays the Bugzilla favicon

Version 	43.0.3
Build ID 	20151223140742
User Agent 	Mozilla/5.0 (Windows NT 10.0; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
Status: UNCONFIRMED → NEW
Component: Untriaged → Bookmarks & History
Ever confirmed: true

Updated

2 years ago
See Also: → bug 1235645
Priority: -- → P5
You need to log in before you can comment on or make changes to this bug.