style sheet isn't applied

RESOLVED INVALID

Status

()

Core
Layout
RESOLVED INVALID
17 years ago
17 years ago

People

(Reporter: Peter Haglund, Assigned: Marc Attinasi)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; Q312461)
BuildID:    2002020406

Mozilla doesn't apply the style sheet, although both the page and the style 
sheet are valid xhtml/css. Netscape 6.2, MSIE 6, and Opera 6 all display the 
page without problems.

Reproducible: Always
Steps to Reproduce:
1. Visit http://w1.555.telia.com/~u55504319


Actual Results:  Default colours, fonts, et cetera are used despite that there 
is a style sheet associated with the page.

Expected Results:  It should have applied the CSS.

Comment 1

17 years ago
The style sheet is served as "text/plain" instead of "text/css" and the page is
rendered in strict mode, so according to the release notes of 0.9.7 the style
sheet won't load.

I think that there's a bug about throwing this kind of errors to the console,
but I just can't find it.

From the release notes of 0.9.7:
    * To add the proper css mime type to an Apache web servers, add "text/css
css" to the system mime.types file. Or if you can't do that, add "AddType
text/css .css" to your .htaccess file.

Reporter:
This bug is invalid (if you fix it) or evangelism if you can't change the server.

Comment 2

17 years ago
confirming Alfonso comments.
I typed http://w1.555.telia.com/~u55504319/styles/main.css in the URL bar
and then View->Page Info shows that the file is served as "text/plain".

I should add to comment #1 that another way to solve your problem is
to remove the strict mode but since you're in XHTML.....

Should be resolved as INVALID.
(Reporter)

Comment 3

17 years ago
That isn't a strict document; it is transitional, and is declared as such.
if you declare a valid doctype then the document is parsed strictly according to
that specification.
C:\aa>wget http://w1.555.telia.com/~u55504319/styles/main.css
--21:35:59--  http://w1.555.telia.com/%7Eu55504319/styles/main.css
           => `main.css'
Connecting to w1.555.telia.com:80... connected!
HTTP request sent, awaiting response... 200 OK
Length: 854 [text/plain]

and Mozilla is in the stricht mode (see the new Page Info in the nightlys) ->
invalid
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.