Closed Bug 1235724 Opened 5 years ago Closed 5 years ago

Update pdf.js to version 1.3.142

Categories

(Firefox :: PDF Viewer, task)

task
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 46
Tracking Status
firefox46 --- fixed

People

(Reporter: RyanVM, Assigned: RyanVM)

References

(Blocks 1 open bug)

Details

+++ This bug was initially created as a clone of Bug #1233801 +++

Changes since last update:
#6778 Fixing externalLinkTarget
#6772 Remove a superfluous "s" in `AnnotationsLayerBuilder` from files in web/
#6770 Refactor annotation display layer code to use classes
#6780 Implement annotation layer regression testing
#6787 Change test-case `issue4914` to an `annotations` test
#6785 Adds/modifies examples for node.js and webpack.
#6792 Implement support for Popup annotations
#6805 Do not modify `data.rect` in `AnnotationElement_createContainer`, since that will corrupt the annotation position on subsequent calls
#6808 Rename and reorder link annotation CSS
#6814 Ensure that the `baseTransform` is applied when rendering annotations
#6807 Ensure that hidden popups do not use any space
#6813 Implement support for Underline annotations
#6821 Bug 951051 - Better crypto key length recovery.
#6771 Removes hardcoded module loading order
https://hg.mozilla.org/mozilla-central/rev/804529fa0c02
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 46
Blocks: 1237815
No longer blocks: 1237815
Type: defect → task
No longer depends on: 1233801
You need to log in before you can comment on or make changes to this bug.