JSON Viewer breaks page ends with .json

RESOLVED DUPLICATE of bug 1235118

Status

()

Firefox
Developer Tools: JSON Viewer
RESOLVED DUPLICATE of bug 1235118
2 years ago
2 years ago

People

(Reporter: xidorn, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Not all pages with .json in the end is really a JSON file. It is especially true for source code viewing.

Pages like:
https://github.com/w3c/wpt-tools/blob/master/scripts/package.json or
https://dxr.mozilla.org/mozilla-central/source/testing/talos/talos.json
are perfect html pages, which are treated as JSON and broken on Firefox Developer Edition.

This is only reproducible on Firefox Developer Edition, which I guess is because only DE has "devtools.jsonview.enabled" set to true by default.

I guess it is a regression from bug 1230544.
Flags: needinfo?(odvarko)
Duplicate of this bug: 1235609

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1235118
Work in progress in bug 1235118.

Honza
Flags: needinfo?(odvarko)
You need to log in before you can comment on or make changes to this bug.