Mathml math renders with excessive vertical space.

RESOLVED DUPLICATE of bug 1208776

Status

()

Core
MathML
RESOLVED DUPLICATE of bug 1208776
2 years ago
2 years ago

People

(Reporter: Adrian Neumann, Unassigned)

Tracking

43 Branch
Unspecified
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

2 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151223140742

Steps to reproduce:

I have a website that uses a piece of javascript to convert Latex Markup to MathML. See for example this page

https://adriann.github.io/cuckoo.html

In the past, this looked fine, similar to how Safari renders the page [1]. Now there is too much vertical space around the math [2]. I don't think it's a problem with the script, or my site being broken somehow, because the same behaviour [3] appears on this MathML page by Mozilla:

https://developer.mozilla.org/en/docs/Web/MathML/Element/mi

I don't know which version of Firefox I used when it last worked. The broken behaviour happens on 43.0.3 on Mac OS 10.8.5.

[1] http://imgur.com/5NVLBvB
[2] http://imgur.com/Hf7PSTZ
[3] http://imgur.com/1JZj4Tr


Actual results:

MathML math has huge vertical whitespace.


Expected results:

Vertical space should be about the size of the rendered math.
(Reporter)

Updated

2 years ago
OS: Unspecified → Mac OS X
This is probably a duplicate of bug 1208776. Be sure to install the latest version of math fonts, for example http://www.gust.org.pl/projects/e-foundry/lm-math
(Reporter)

Comment 2

2 years ago
Indeed, updating my fonts fixed the problem.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1208776
You need to log in before you can comment on or make changes to this bug.