If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Intermittent testAppMenuPathways | Menu is open

RESOLVED WORKSFORME

Status

()

Firefox for Android
Testing
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: philor, Assigned: gbrown)

Tracking

({intermittent-failure})

Trunk
ARM
Android
intermittent-failure
Points:
---

Firefox Tracking Flags

(firefox46 affected)

Details

(Reporter)

Description

2 years ago
https://treeherder.mozilla.org/logviewer.html#?job_id=2969906&repo=mozilla-central
 04:16:13  WARNING -  TEST-UNEXPECTED-FAIL | testAppMenuPathways | Menu is open -
 04:16:13     INFO -  0 ERROR Exception caught during test! - junit.framework.AssertionFailedError: TEST-UNEXPECTED-FAIL | testAppMenuPathways | Menu is open -
 04:16:13     INFO -  	at junit.framework.Assert.fail(Assert.java:47)
 04:16:13     INFO -  	at org.mozilla.gecko.FennecMochitestAssert._logMochitestResult(FennecMochitestAssert.java:128)
 04:16:13     INFO -  	at org.mozilla.gecko.FennecMochitestAssert.ok(FennecMochitestAssert.java:150)
 04:16:13     INFO -  	at org.mozilla.gecko.tests.helpers.AssertionHelper.fAssertTrue(AssertionHelper.java:98)
 04:16:13     INFO -  	at org.mozilla.gecko.tests.components.AppMenuComponent.pressMenuItem(AppMenuComponent.java:211)
 04:16:13     INFO -  	at org.mozilla.gecko.tests.components.AppMenuComponent.assertMenuItemIsDisabledAndVisible(AppMenuComponent.java:118)
 04:16:13     INFO -  	at org.mozilla.gecko.tests.testAppMenuPathways._testSaveAsPDFPathway(testAppMenuPathways.java:30)
 04:16:13     INFO -  	at org.mozilla.gecko.tests.testAppMenuPathways.testAppMenuPathways(testAppMenuPathways.java:25)
(Assignee)

Comment 2

2 years ago
testAppMenuPathways is being enabled today in bug 1235689. 

I did not reproduce this bug in try runs, so I'll just watch it for a week in hopes of closing it soon.
Assignee: nobody → gbrown
(Assignee)

Comment 3

2 years ago
No failures since AppMenuComponent updated and testAppMenuPathways enabled.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.