Intermittent TEST-UNEXPECTED-FAIL | apps/system/test/marionette/browser_video_test.js | Video Confirm video playback

RESOLVED FIXED in 2.6 S6 - 1/29

Status

Firefox OS
Gaia::Browser
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mikehenrty, Assigned: tilman)

Tracking

({intermittent-failure})

unspecified
2.6 S6 - 1/29
x86
Gonk (Firefox OS)
intermittent-failure

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [systemsfe][MJS])

Attachments

(4 attachments)

Created attachment 8702980 [details]
[screenshot] failure state

TEST-UNEXPECTED-FAIL | apps/system/test/marionette/browser_video_test.js | Video Confirm video playback
Error: timeout exceeded!
    at Object.Client.waitForSync (node_modules/marionette-client/lib/marionette/client.js:760:16)
    at Object.Client.waitFor (node_modules/marionette-client/lib/marionette/client.js:726:60)
    at Object.VideoPlayer.tapMute (apps/system/test/marionette/lib/video_player.js:115:17)
    at Context.<anonymous> (apps/system/test/marionette/browser_video_test.js:61:12)
    at Test.MarionetteTest.run (node_modules/marionette-js-runner/lib/ui.js:25:31)
    at node_modules/marionette-js-runner/node_modules/promise/lib/core.js:33:15
    at flush (node_modules/marionette-js-runner/node_modules/promise/node_modules/asap/asap.js:27:13)

https://treeherder.mozilla.org/logviewer.html#?job_id=3248523&repo=gaia

Comment 1

2 years ago
13 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 4
* b2g-inbound: 4
* mozilla-central: 2
* gaia: 2
* fx-team: 1

Platform breakdown:
* b2g-linux64: 6
* mulet-linux64: 5
* gaia: 2

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1235881&startday=2015-12-28&endday=2016-01-03&tree=all

Comment 2

2 years ago
19 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 13
* fx-team: 5
* b2g-inbound: 1

Platform breakdown:
* mulet-linux64: 19

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1235881&startday=2016-01-05&endday=2016-01-05&tree=all
Disabled in master: https://github.com/mozilla-b2g/gaia/commit/214fe4da5430878160b5e3a2d7770fffab32eacf
Keywords: leave-open
Tilman, can you see why this is failing so often on automation?
Assignee: nobody → tilmankamp

Comment 5

2 years ago
27 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 17
* fx-team: 6
* b2g-inbound: 4

Platform breakdown:
* mulet-linux64: 27

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1235881&startday=2016-01-04&endday=2016-01-10&tree=all

Comment 6

2 years ago
Created attachment 8706256 [details] [review]
[gaia] tilmankamp:fix-1235881 > mozilla-b2g:master
(Assignee)

Updated

2 years ago
Status: NEW → ASSIGNED
(Assignee)

Updated

2 years ago
Attachment #8706256 - Flags: review?(mhenretty)
Comment on attachment 8706256 [details] [review]
[gaia] tilmankamp:fix-1235881 > mozilla-b2g:master

Great! I'm forwarding this along to Alberto since he originally converted this test from the python tests.
Attachment #8706256 - Flags: review?(mhenretty) → review?(apastor)
Comment on attachment 8706256 [details] [review]
[gaia] tilmankamp:fix-1235881 > mozilla-b2g:master

I followed the same approach originally, but I had some issues when taping on the fullscreen control. I don't remember exactly what was exactly the issue, and the code makes more sense to me now, so r+! Thanks!
Attachment #8706256 - Flags: review?(apastor) → review+
(Assignee)

Comment 9

2 years ago
Merged into master:
https://github.com/tilmankamp/gaia/commit/071c78b53875aa5f577359b0b734fa9e7808a86e
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED

Comment 10

2 years ago
16 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 11
* b2g-inbound: 3
* fx-team: 2

Platform breakdown:
* mulet-linux64: 16

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1235881&startday=2016-01-12&endday=2016-01-12&tree=all
Nope, still happening.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Re-disabling this while we investigate.

https://github.com/mozilla-b2g/gaia/commit/9a3588ae825abd3cb2b1b696cefb0c020b82ecdc

Comment 13

2 years ago
17 automation job failures were associated with this bug yesterday.

Repository breakdown:
* mozilla-inbound: 10
* fx-team: 5
* b2g-inbound: 2

Platform breakdown:
* mulet-linux64: 17

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1235881&startday=2016-01-13&endday=2016-01-13&tree=all

Comment 14

2 years ago
Created attachment 8707941 [details] [review]
[gaia] tilmankamp:u1235881 > mozilla-b2g:master
(Assignee)

Updated

2 years ago
Attachment #8707941 - Flags: review?(mhenretty)
(Assignee)

Updated

2 years ago
Attachment #8707941 - Flags: review?(apastor)
Hey! Left a couple of comments in GH
Flags: needinfo?(tilman)
(Assignee)

Comment 16

2 years ago
(In reply to Alberto Pastor [:albertopq] from comment #15)
> Hey! Left a couple of comments in GH

You can find my answers there.
Flags: needinfo?(tilman)
Comment on attachment 8707941 [details] [review]
[gaia] tilmankamp:u1235881 > mozilla-b2g:master

Worth a try :)
Attachment #8707941 - Flags: review?(mhenretty) → review+
(Assignee)

Comment 18

2 years ago
Created attachment 8708315 [details]
red.mov

The attached video illustrates some unexpected behavior (please look at it slowly/frame by frame). After the second "tapFullscreen..." in the terminal, the control panel should disappear and the browser should leave full-screen mode and show some chrome. The actual result in this case: The control panel disappears, reappears again and no chrome is coming up. Probability of this effect is somewhere around 1/30.
(Assignee)

Comment 19

2 years ago
The last comment is related to the state before 
[gaia] tilmankamp:u1235881 > mozilla-b2g:master

Comment 20

2 years ago
42 automation job failures were associated with this bug in the last 7 days.

Repository breakdown:
* mozilla-inbound: 27
* fx-team: 9
* b2g-inbound: 6

Platform breakdown:
* mulet-linux64: 42

For more details, see:
https://brasstacks.mozilla.com/orangefactor/?display=Bug&bugid=1235881&startday=2016-01-11&endday=2016-01-17&tree=all
(In reply to Tilman Kamp [:tilman] from comment #18)
> Created attachment 8708315 [details]
> red.mov
> 
> The attached video illustrates some unexpected behavior (please look at it
> slowly/frame by frame). After the second "tapFullscreen..." in the terminal,
> the control panel should disappear and the browser should leave full-screen
> mode and show some chrome. The actual result in this case: The control panel
> disappears, reappears again and no chrome is coming up. Probability of this
> effect is somewhere around 1/30.

Just thinking out loud, could the click on the fullscreen permission dialog be causing this? Not sure how to check it, so let's just merge it if the probability is so low
Attachment #8707941 - Flags: review?(apastor) → review+
(Assignee)

Comment 22

2 years ago
Comment on attachment 8707941 [details] [review]
[gaia] tilmankamp:u1235881 > mozilla-b2g:master

Merged into master
https://github.com/tilmankamp/gaia/commit/f4593e03da5dcabcd630929438104fd6ebb41a31
(Assignee)

Comment 23

2 years ago
I leave it on REOPENED for now. Let's see if it solved the problem.
(Assignee)

Comment 24

2 years ago
No orange yet.
Status: REOPENED → RESOLVED
Last Resolved: 2 years ago2 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2.6 S6 - 1/29
Keywords: leave-open
You need to log in before you can comment on or make changes to this bug.